Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "Library providing simplified C and Python API to libsolv" |
| 2 | LICENSE = "LGPLv2.1" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c" |
| 4 | |
| 5 | SRC_URI = "git://github.com/rpm-software-management/libdnf \ |
| 6 | file://0001-FindGtkDoc.cmake-drop-the-requirement-for-GTKDOC_SCA.patch \ |
| 7 | file://0002-Prefix-sysroot-path-to-introspection-tools-path.patch \ |
| 8 | file://0003-Set-the-library-installation-directory-correctly.patch \ |
| 9 | file://0004-Set-libsolv-variables-with-pkg-config-cmake-s-own-mo.patch \ |
| 10 | file://0001-Get-parameters-for-both-libsolv-and-libsolvext-libdn.patch \ |
| 11 | " |
| 12 | |
| 13 | SRCREV = "60f979bd8db651229c559c1412f1eb880257127d" |
| 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
| 17 | DEPENDS = "glib-2.0 libsolv libcheck librepo rpm gtk-doc" |
| 18 | |
| 19 | inherit gtk-doc gobject-introspection cmake pkgconfig distutils3-base |
| 20 | |
| 21 | EXTRA_OECMAKE = " -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DWITH_MAN=OFF -DPYTHON_DESIRED=3 \ |
| 22 | ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '-DWITH_GIR=ON', '-DWITH_GIR=OFF', d)} \ |
| 23 | " |
| 24 | EXTRA_OECMAKE_append_class-native = " -DWITH_GIR=OFF" |
| 25 | EXTRA_OECMAKE_append_class-nativesdk = " -DWITH_GIR=OFF" |
| 26 | |
| 27 | BBCLASSEXTEND = "native nativesdk" |
| 28 | |