Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 1 | SECTION = "console/network" |
| 2 | SUMMARY = "dhcpcd - a DHCP client" |
| 3 | DESCRIPTION = "dhcpcd runs on your machine and silently configures your \ |
| 4 | computer to work on the attached networks without trouble \ |
| 5 | and mostly without configuration." |
| 6 | |
| 7 | HOMEPAGE = "http://roy.marples.name/projects/dhcpcd/" |
| 8 | |
| 9 | LICENSE = "BSD-2-Clause" |
| 10 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d148485768fe85b9f1072b186a7e9b4d" |
| 11 | |
| 12 | UPSTREAM_CHECK_URI = "https://roy.marples.name/downloads/dhcpcd/" |
| 13 | |
| 14 | SRC_URI = "https://roy.marples.name/downloads/${BPN}/${BPN}-${PV}.tar.xz \ |
| 15 | file://0001-remove-INCLUDEDIR-to-prevent-build-issues.patch \ |
| 16 | file://dhcpcd.service \ |
| 17 | file://dhcpcd@.service \ |
| 18 | " |
| 19 | |
| 20 | SRC_URI[sha256sum] = "819357634efed1ea5cf44ec01b24d3d3f8852fec8b4249925dcc5667c54e376c" |
| 21 | |
| 22 | inherit pkgconfig autotools-brokensep systemd useradd |
| 23 | |
| 24 | SYSTEMD_SERVICE:${PN} = "dhcpcd.service" |
| 25 | |
| 26 | PACKAGECONFIG ?= "udev ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}" |
| 27 | |
| 28 | PACKAGECONFIG[udev] = "--with-udev,--without-udev,udev,udev" |
| 29 | PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6" |
| 30 | # ntp conflicts with chrony |
| 31 | PACKAGECONFIG[ntp] = "--with-hook=ntp, , ,ntp" |
| 32 | PACKAGECONFIG[chrony] = "--with-hook=ntp, , ,chrony" |
| 33 | PACKAGECONFIG[ypbind] = "--with-eghook=yp, , ,ypbind-mt" |
| 34 | |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 35 | # add option to override DBDIR location |
| 36 | DBDIR ?= "${localstatedir}/lib/${BPN}" |
| 37 | |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 38 | EXTRA_OECONF = "--enable-ipv4 \ |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 39 | --dbdir=${DBDIR} \ |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 40 | --sbindir=${base_sbindir} \ |
| 41 | --runstatedir=/run \ |
| 42 | --enable-privsep \ |
| 43 | --privsepuser=dhcpcd \ |
| 44 | --with-hooks \ |
| 45 | --with-eghooks \ |
| 46 | " |
| 47 | |
| 48 | USERADD_PACKAGES = "${PN}" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 49 | USERADD_PARAM:${PN} = "--system -d ${DBDIR} -M -s /bin/false -U dhcpcd" |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 50 | |
| 51 | do_install:append () { |
| 52 | # install systemd unit files |
| 53 | install -d ${D}${systemd_system_unitdir} |
| 54 | install -m 0644 ${WORKDIR}/dhcpcd*.service ${D}${systemd_system_unitdir} |
| 55 | |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 56 | chmod 700 ${D}${DBDIR} |
| 57 | chown dhcpcd:dhcpcd ${D}${DBDIR} |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 58 | } |
| 59 | |
| 60 | FILES:${PN}-dbg += "${libdir}/dhcpcd/dev/.debug" |