blob: d440e60ee6080c8f827ef7166159c77f24b7c756 [file] [log] [blame]
Andrew Geissler4b740dc2020-05-05 08:54:39 -05001SUMMARY = "C Library for manipulating module metadata files"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://COPYING;md5=25a3927bff3ee4f5b21bcb0ed3fcd6bb"
4
5SRC_URI = "git://github.com/fedora-modularity/libmodulemd;protocol=https \
6 file://0001-modulemd-generate-the-manpage-only-if-the-feature-is.patch \
7 file://0002-meson.build-do-not-install-python-gi-bindings.patch \
8 "
9
10PV = "2.9.2"
11SRCREV = "780750eab8a0587b20d033f335301f16d00ab9c9"
12
13S = "${WORKDIR}/git"
14
15inherit meson gobject-introspection
16
17EXTRA_OEMESON = "-Ddeveloper_build=false -Dwith_docs=false -Drpmio=disabled -Dlibmagic=disabled -Dwith_manpages=disabled"
18
19DEPENDS += "glib-2.0 libyaml glib-2.0-native python3"
20
21BBCLASSEXTEND = "native nativesdk"
22
23GIR_MESON_OPTION = 'skip_introspection'
24GIR_MESON_ENABLE_FLAG = 'false'
25GIR_MESON_DISABLE_FLAG = 'true'