Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | DESCRIPTION = "Simple DirectMedia Layer networking library." |
| 2 | SECTION = "libs/network" |
| 3 | LICENSE = "Zlib" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING.txt;md5=fe9d52a78585a65224776875510ed127" |
| 5 | |
| 6 | SRC_URI = " \ |
| 7 | https://www.libsdl.org/projects/SDL_net/release/SDL2_net-${PV}.tar.gz \ |
| 8 | " |
| 9 | S = "${WORKDIR}/SDL2_net-${PV}" |
| 10 | |
| 11 | inherit autotools pkgconfig |
| 12 | |
| 13 | DEPENDS = "virtual/libsdl2" |
| 14 | |
| 15 | SRC_URI[md5sum] = "5c1d9d1cfa63301b141cb5c0de2ea7c4" |
| 16 | SRC_URI[sha256sum] = "15ce8a7e5a23dafe8177c8df6e6c79b6749a03fff1e8196742d3571657609d21" |
| 17 | |
| 18 | do_configure_prepend() { |
| 19 | # create dummy files which autotools consider as mandatory |
| 20 | touch ${S}/NEWS ${S}/README ${S}/AUTHORS ${S}/ChangeLog |
| 21 | |
| 22 | # Remove old libtool macros. |
| 23 | for macro in libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4; do |
| 24 | echo ${S}/acinclude/macro |
| 25 | rm -f ${S}/acinclude/$macro |
| 26 | done |
| 27 | } |