Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 1 | KBRANCH ?= "v5.2/standard/tiny/base" |
| 2 | KBRANCH_qemuarm ?= "v5.2/standard/tiny/arm-versatile-926ejs" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 3 | |
| 4 | LINUX_KERNEL_TYPE = "tiny" |
| 5 | KCONFIG_MODE = "--allnoconfig" |
| 6 | |
| 7 | require recipes-kernel/linux/linux-yocto.inc |
| 8 | |
Brad Bishop | 64c979e | 2019-11-04 13:55:29 -0500 | [diff] [blame] | 9 | LINUX_VERSION ?= "5.2.20" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814" |
| 11 | |
| 12 | DEPENDS += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-native', '', d)}" |
| 13 | DEPENDS += "openssl-native util-linux-native" |
| 14 | |
| 15 | KMETA = "kernel-meta" |
| 16 | KCONF_BSP_AUDIT_LEVEL = "2" |
| 17 | |
Brad Bishop | 64c979e | 2019-11-04 13:55:29 -0500 | [diff] [blame] | 18 | SRCREV_machine_qemuarm ?= "501d680535903acc00808c36f2cc07f2dc725adc" |
| 19 | SRCREV_machine ?= "dd25a04fc5e2e4549fc9b86157a01e0c72b53b03" |
| 20 | SRCREV_meta ?= "bd0762cd138f1624b5a5f8669cfa3ac2b71cb87b" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 21 | |
| 22 | PV = "${LINUX_VERSION}+git${SRCPV}" |
| 23 | |
| 24 | SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \ |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 25 | git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-5.2;destsuffix=${KMETA}" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 26 | |
| 27 | COMPATIBLE_MACHINE = "qemux86|qemux86-64|qemuarm|qemuarmv5" |
| 28 | |
| 29 | # Functionality flags |
| 30 | KERNEL_FEATURES = "" |
| 31 | |
Brad Bishop | f3fd288 | 2019-06-21 08:06:37 -0400 | [diff] [blame] | 32 | KERNEL_DEVICETREE_qemuarmv5 = "versatile-pb.dtb" |