Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "web server scanner" |
| 2 | DESCRIPTION = "Nikto is an Open Source web server scanner which performs comprehensive tests against web servers" |
| 3 | SECTION = "security" |
| 4 | HOMEPAGE = "https://cirt.net/Nikto2" |
| 5 | |
| 6 | LICENSE = "GPLv2" |
Andrew Geissler | 8b13928 | 2021-03-05 15:22:30 -0600 | [diff] [blame] | 7 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0-only;md5=801f80980d171dd6425610833a22dbe6" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 8 | |
| 9 | SRCREV = "f1bbd1a8756c076c8fd4f4dd0bc34a8ef215ae79" |
| 10 | SRC_URI = "git://github.com/sullo/nikto.git \ |
| 11 | file://location.patch" |
| 12 | |
| 13 | S = "${WORKDIR}/git/program" |
| 14 | |
| 15 | do_install() { |
| 16 | install -d ${D}${bindir} |
| 17 | install -d ${D}${datadir} |
| 18 | install -d ${D}${datadir}/man/man1 |
| 19 | install -d ${D}${datadir}/doc/nikto |
| 20 | install -d ${D}${sysconfdir}/nikto |
| 21 | install -d ${D}${sysconfdir}/nikto/databases |
| 22 | install -d ${D}${sysconfdir}/nikto/plugins |
| 23 | install -d ${D}${sysconfdir}/nikto/templates |
| 24 | |
| 25 | install -m 0644 databases/db_404_strings ${D}${sysconfdir}/nikto/databases |
| 26 | install -m 0644 databases/db_content_search ${D}${sysconfdir}/nikto/databases |
| 27 | install -m 0644 databases/db_dictionary ${D}${sysconfdir}/nikto/databases |
| 28 | install -m 0644 databases/db_dir_traversal ${D}${sysconfdir}/nikto/databases |
| 29 | install -m 0644 databases/db_domino ${D}${sysconfdir}/nikto/databases |
| 30 | install -m 0644 databases/db_drupal ${D}${sysconfdir}/nikto/databases |
| 31 | install -m 0644 databases/db_embedded ${D}${sysconfdir}/nikto/databases |
| 32 | install -m 0644 databases/db_favicon ${D}${sysconfdir}/nikto/databases |
| 33 | install -m 0644 databases/db_headers ${D}${sysconfdir}/nikto/databases |
| 34 | install -m 0644 databases/db_httpoptions ${D}${sysconfdir}/nikto/databases |
| 35 | install -m 0644 databases/db_multiple_index ${D}${sysconfdir}/nikto/databases |
| 36 | install -m 0644 databases/db_outdated ${D}${sysconfdir}/nikto/databases |
| 37 | install -m 0644 databases/db_parked_strings ${D}${sysconfdir}/nikto/databases |
| 38 | install -m 0644 databases/db_realms ${D}${sysconfdir}/nikto/databases |
| 39 | install -m 0644 databases/db_server_msgs ${D}${sysconfdir}/nikto/databases |
| 40 | install -m 0644 databases/db_tests ${D}${sysconfdir}/nikto/databases |
| 41 | install -m 0644 databases/db_variables ${D}${sysconfdir}/nikto/databases |
| 42 | |
| 43 | install -m 0644 plugins/LW2.pm ${D}${sysconfdir}/nikto/plugins |
| 44 | install -m 0644 plugins/nikto_apache_expect_xss.plugin ${D}${sysconfdir}/nikto/plugins |
| 45 | install -m 0644 plugins/nikto_apacheusers.plugin ${D}${sysconfdir}/nikto/plugins |
| 46 | install -m 0644 plugins/nikto_auth.plugin ${D}${sysconfdir}/nikto/plugins |
| 47 | install -m 0644 plugins/nikto_cgi.plugin ${D}${sysconfdir}/nikto/plugins |
| 48 | install -m 0644 plugins/nikto_clientaccesspolicy.plugin ${D}${sysconfdir}/nikto/plugins |
| 49 | install -m 0644 plugins/nikto_content_search.plugin ${D}${sysconfdir}/nikto/plugins |
| 50 | install -m 0644 plugins/nikto_cookies.plugin ${D}${sysconfdir}/nikto/plugins |
| 51 | install -m 0644 plugins/nikto_core.plugin ${D}${sysconfdir}/nikto/plugins |
| 52 | install -m 0644 plugins/nikto_dictionary_attack.plugin ${D}${sysconfdir}/nikto/plugins |
| 53 | install -m 0644 plugins/nikto_dir_traversal.plugin ${D}${sysconfdir}/nikto/plugins |
| 54 | install -m 0644 plugins/nikto_dishwasher.plugin ${D}${sysconfdir}/nikto/plugins |
| 55 | install -m 0644 plugins/nikto_docker_registry.plugin ${D}${sysconfdir}/nikto/plugins |
| 56 | install -m 0644 plugins/nikto_domino.plugin ${D}${sysconfdir}/nikto/plugins |
| 57 | install -m 0644 plugins/nikto_drupal.plugin ${D}${sysconfdir}/nikto/plugins |
| 58 | install -m 0644 plugins/nikto_embedded.plugin ${D}${sysconfdir}/nikto/plugins |
| 59 | install -m 0644 plugins/nikto_favicon.plugin ${D}${sysconfdir}/nikto/plugins |
| 60 | install -m 0644 plugins/nikto_fileops.plugin ${D}${sysconfdir}/nikto/plugins |
| 61 | install -m 0644 plugins/nikto_headers.plugin ${D}${sysconfdir}/nikto/plugins |
| 62 | install -m 0644 plugins/nikto_httpoptions.plugin ${D}${sysconfdir}/nikto/plugins |
| 63 | install -m 0644 plugins/nikto_ms10_070.plugin ${D}${sysconfdir}/nikto/plugins |
| 64 | install -m 0644 plugins/nikto_msgs.plugin ${D}${sysconfdir}/nikto/plugins |
| 65 | install -m 0644 plugins/nikto_multiple_index.plugin ${D}${sysconfdir}/nikto/plugins |
| 66 | install -m 0644 plugins/nikto_negotiate.plugin ${D}${sysconfdir}/nikto/plugins |
| 67 | install -m 0644 plugins/nikto_origin_reflection.plugin ${D}${sysconfdir}/nikto/plugins |
| 68 | install -m 0644 plugins/nikto_outdated.plugin ${D}${sysconfdir}/nikto/plugins |
| 69 | install -m 0644 plugins/nikto_parked.plugin ${D}${sysconfdir}/nikto/plugins |
| 70 | install -m 0644 plugins/nikto_paths.plugin ${D}${sysconfdir}/nikto/plugins |
| 71 | install -m 0644 plugins/nikto_put_del_test.plugin ${D}${sysconfdir}/nikto/plugins |
| 72 | install -m 0644 plugins/nikto_report_csv.plugin ${D}${sysconfdir}/nikto/plugins |
| 73 | install -m 0644 plugins/nikto_report_html.plugin ${D}${sysconfdir}/nikto/plugins |
| 74 | install -m 0644 plugins/nikto_report_json.plugin ${D}${sysconfdir}/nikto/plugins |
| 75 | install -m 0644 plugins/nikto_report_nbe.plugin ${D}${sysconfdir}/nikto/plugins |
| 76 | install -m 0644 plugins/nikto_report_sqlg.plugin ${D}${sysconfdir}/nikto/plugins |
| 77 | install -m 0644 plugins/nikto_report_text.plugin ${D}${sysconfdir}/nikto/plugins |
| 78 | install -m 0644 plugins/nikto_report_xml.plugin ${D}${sysconfdir}/nikto/plugins |
| 79 | install -m 0644 plugins/nikto_robots.plugin ${D}${sysconfdir}/nikto/plugins |
| 80 | install -m 0644 plugins/nikto_siebel.plugin ${D}${sysconfdir}/nikto/plugins |
| 81 | install -m 0644 plugins/nikto_sitefiles.plugin ${D}${sysconfdir}/nikto/plugins |
| 82 | install -m 0644 plugins/nikto_ssl.plugin ${D}${sysconfdir}/nikto/plugins |
| 83 | install -m 0644 plugins/nikto_strutshock.plugin ${D}${sysconfdir}/nikto/plugins |
| 84 | install -m 0644 plugins/nikto_tests.plugin ${D}${sysconfdir}/nikto/plugins |
| 85 | |
| 86 | install -m 0644 templates/htm_close.tmpl ${D}${sysconfdir}/nikto/templates |
| 87 | install -m 0644 templates/htm_end.tmpl ${D}${sysconfdir}/nikto/templates |
| 88 | install -m 0644 templates/htm_host_head.tmpl ${D}${sysconfdir}/nikto/templates |
| 89 | install -m 0644 templates/htm_host_im.tmpl ${D}${sysconfdir}/nikto/templates |
| 90 | install -m 0644 templates/htm_host_item.tmpl ${D}${sysconfdir}/nikto/templates |
| 91 | install -m 0644 templates/htm_start.tmpl ${D}${sysconfdir}/nikto/templates |
| 92 | install -m 0644 templates/htm_stop.tmpl ${D}${sysconfdir}/nikto/templates |
| 93 | install -m 0644 templates/htm_start.tmpl ${D}${sysconfdir}/nikto/templates |
| 94 | install -m 0644 templates/htm_summary.tmpl ${D}${sysconfdir}/nikto/templates |
| 95 | install -m 0644 templates/xml_end.tmpl ${D}${sysconfdir}/nikto/templates |
| 96 | install -m 0644 templates/xml_host_head.tmpl ${D}${sysconfdir}/nikto/templates |
| 97 | install -m 0644 templates/xml_host_im.tmpl ${D}${sysconfdir}/nikto/templates |
| 98 | install -m 0644 templates/xml_host_item.tmpl ${D}${sysconfdir}/nikto/templates |
| 99 | install -m 0644 templates/xml_start.tmpl ${D}${sysconfdir}/nikto/templates |
| 100 | install -m 0644 templates/xml_summary.tmpl ${D}${sysconfdir}/nikto/templates |
| 101 | |
| 102 | install -m 0644 nikto.conf ${D}${sysconfdir} |
| 103 | |
| 104 | install -m 0755 nikto.pl ${D}${bindir}/nikto |
| 105 | install -m 0644 replay.pl ${D}${bindir} |
| 106 | install -m 0644 docs/nikto.1 ${D}${datadir}/man/man1 |
| 107 | |
| 108 | install -m 0644 docs/CHANGES.txt ${D}${datadir}/doc/nikto |
| 109 | install -m 0644 docs/LICENSE.txt ${D}${datadir}/doc/nikto |
| 110 | install -m 0644 docs/nikto.dtd ${D}${datadir}/doc/nikto |
| 111 | install -m 0644 docs/nikto_manual.html ${D}${datadir}/doc/nikto |
| 112 | } |
| 113 | |
| 114 | RDEPENDS_${PN} = "perl libnet-ssleay-perl libwhisker2-perl \ |
| 115 | perl-module-getopt-long perl-module-time-local \ |
| 116 | perl-module-io-socket perl-module-overloading \ |
| 117 | perl-module-base perl-module-b perl-module-bytes" |
| 118 | |