Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "A log file analysis program" |
| 2 | DESCRIPTION = "\ |
| 3 | Logwatch is a customizable, pluggable log-monitoring system. It will go \ |
| 4 | through your logs for a given period of time and make a report in the areas \ |
| 5 | that you wish with the detail that you wish. Easy to use - works right out of \ |
| 6 | the package on many systems.\ |
| 7 | " |
| 8 | SECTION = "devel" |
| 9 | HOMEPAGE = "http://www.logwatch.org/" |
| 10 | LICENSE = "MIT" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 11 | LIC_FILES_CHKSUM = "file://LICENSE;md5=ad199c8aca74e70f296f731ad9a1521c" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 12 | RDEPENDS:${PN} = "perl" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 13 | |
| 14 | SRC_URI = "http://jaist.dl.sourceforge.net/project/${BPN}/${BP}/${BP}.tar.gz" |
Andrew Geissler | eafcbb8 | 2020-06-05 17:59:17 -0500 | [diff] [blame] | 15 | SRC_URI[md5sum] = "8bcf3edc5a4687c8aad1b9c01e2be54b" |
| 16 | SRC_URI[sha256sum] = "1b2b96879dec01cd02754fe00f8989b11ff16158c3dc7c4aff0faa4b1d34974b" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 17 | |
| 18 | do_install() { |
| 19 | install -m 0755 -d ${D}${sysconfdir}/logwatch/scripts |
| 20 | install -m 0755 -d ${D}${datadir}/logwatch/dist.conf/logfiles |
| 21 | install -m 0755 -d ${D}${datadir}/logwatch/dist.conf/services |
| 22 | install -m 0755 -d ${D}${localstatedir}/cache/logwatch |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 23 | cp -r -f conf/ ${D}${datadir}/logwatch/default.conf |
| 24 | cp -r -f scripts/ ${D}${datadir}/logwatch/scripts |
| 25 | cp -r -f lib ${D}${datadir}/logwatch/lib |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 26 | chown -R root:root ${D}${datadir}/logwatch |
| 27 | |
| 28 | install -m 0755 -d ${D}${mandir}/man1 |
| 29 | install -m 0755 -d ${D}${mandir}/man5 |
| 30 | install -m 0755 -d ${D}${mandir}/man8 |
| 31 | install -m 0644 amavis-logwatch.1 ${D}${mandir}/man1 |
| 32 | install -m 0644 postfix-logwatch.1 ${D}${mandir}/man1 |
| 33 | install -m 0644 ignore.conf.5 ${D}${mandir}/man5 |
| 34 | install -m 0644 override.conf.5 ${D}${mandir}/man5 |
| 35 | install -m 0644 logwatch.conf.5 ${D}${mandir}/man5 |
| 36 | install -m 0644 logwatch.8 ${D}${mandir}/man8 |
| 37 | |
| 38 | install -m 0755 -d ${D}${sysconfdir}/cron.daily |
| 39 | install -m 0755 -d ${D}${sbindir} |
| 40 | ln -sf ../..${datadir}/logwatch/scripts/logwatch.pl ${D}${sbindir}/logwatch |
| 41 | cat > ${D}${sysconfdir}/cron.daily/0logwatch <<EOF |
| 42 | DailyReport=\`grep -e "^[[:space:]]*DailyReport[[:space:]]*=[[:space:]]*" /usr/share/logwatch/default.conf/logwatch.conf | head -n1 | sed -e "s|^\s*DailyReport\s*=\s*||"\` |
| 43 | if [ "\$DailyReport" != "No" ] && [ "\$DailyReport" != "no" ] |
| 44 | then |
| 45 | logwatch |
| 46 | fi |
| 47 | EOF |
| 48 | chmod 755 ${D}${sysconfdir}/cron.daily/0logwatch |
| 49 | |
| 50 | install -m 0755 -d ${D}${sysconfdir}/logwatch/conf/logfiles |
| 51 | install -m 0755 -d ${D}${sysconfdir}/logwatch/conf/services |
| 52 | touch ${D}${sysconfdir}/logwatch/conf/logwatch.conf |
| 53 | touch ${D}${sysconfdir}/logwatch/conf/ignore.conf |
| 54 | touch ${D}${sysconfdir}/logwatch/conf/override.conf |
| 55 | echo "# Local configuration options go here (defaults are in /usr/share/logwatch/default.conf/logwatch.conf)" > ${D}${sysconfdir}/logwatch/conf/logwatch.conf |
| 56 | echo "###### REGULAR EXPRESSIONS IN THIS FILE WILL BE TRIMMED FROM REPORT OUTPUT #####" > ${D}${sysconfdir}/logwatch/conf/ignore.conf |
| 57 | echo "# Configuration overrides for specific logfiles/services may be placed here." > ${D}${sysconfdir}/logwatch/conf/override.conf |
| 58 | } |