Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "httplib2 caching for requests" |
| 2 | HOMEPAGE = "https://pypi.org/project/CacheControl/" |
| 3 | LICENSE = "Apache-2.0" |
| 4 | LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=12;endline=12;md5=62d6ee40749ec0b76d8a1200a1562369" |
| 5 | |
| 6 | # On PyPi, this is "CacheControl", rather than "cachecontrol", so we need to |
| 7 | # override PYPI_PACKAGE so fetch succeeds. |
| 8 | PYPI_PACKAGE = "CacheControl" |
| 9 | |
| 10 | SRC_URI[sha256sum] = "d8aca75b82eec92d84b5d6eb8c8f66ea16f09d2adb09dbca27fe2d5fc8d3732d" |
| 11 | |
| 12 | inherit pypi setuptools3 |
| 13 | |
| 14 | RDEPENDS:${PN} += "\ |
| 15 | python3-crypt \ |
| 16 | python3-datetime \ |
| 17 | python3-email \ |
| 18 | python3-lockfile \ |
| 19 | python3-json \ |
| 20 | python3-logging \ |
| 21 | python3-msgpack \ |
| 22 | python3-netclient \ |
| 23 | python3-pickle \ |
| 24 | python3-requests \ |
| 25 | python3-urllib3 \ |
| 26 | python3-mmap \ |
| 27 | " |
| 28 | |
| 29 | BBCLASSEXTEND = "native nativesdk" |