Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Convenience functions for dbus services in Python 2.x" |
| 2 | HOMEPAGE = "https://github.com/nphilipp/python-slip" |
| 3 | DESCRIPTION = "\ |
| 4 | The Simple Library for Python 2.x packages contain miscellaneous code for \ |
| 5 | convenience, extension and workaround purposes. \ |
| 6 | \ |
| 7 | This package provides slip.dbus.service.Object, which is a dbus.service.Object \ |
| 8 | derivative that ends itself after a certain time without being used and/or if \ |
| 9 | there are no clients anymore on the message bus, as well as convenience \ |
| 10 | functions and decorators for integrating a dbus service with PolicyKit." |
| 11 | |
| 12 | SECTION = "devel/python" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 13 | LICENSE = "GPL-2.0-or-later" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 14 | LIC_FILES_CHKSUM = "file://COPYING;md5=5574c6965ae5f583e55880e397fbb018" |
| 15 | SRCNAME = "python-slip" |
| 16 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 17 | SRC_URI = "https://github.com/nphilipp/${SRCNAME}/releases/download/${SRCNAME}-${PV}/${SRCNAME}-${PV}.tar.bz2 \ |
| 18 | file://9b939c0b534c1b7958fa0a3c7aedf30bca910431.patch \ |
| 19 | file://0001-setup.py-Use-setuptools-instead-of-distutils.patch \ |
| 20 | " |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 21 | SRC_URI[sha256sum] = "c726c086f0dd93a0ac7a0176f383a12af91b6657b78a301e3f5b25d9f8d4d10b" |
| 22 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 23 | S = "${WORKDIR}/${SRCNAME}-${PV}" |
| 24 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 25 | do_compile:prepend() { |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 26 | sed -e 's/@VERSION@/${PV}/g' ${S}/setup.py.in > ${S}/setup.py |
| 27 | } |
| 28 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 29 | RDEPENDS:${PN} += "\ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 30 | ${PYTHON_PN}-six \ |
| 31 | " |
| 32 | # http://errors.yoctoproject.org/Errors/Details/184713/ |
| 33 | # python-native/python: can't open file 'setup.py': [Errno 2] No such file or directory |
| 34 | CLEANBROKEN = "1" |
| 35 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 36 | inherit setuptools3 |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 37 | PIP_INSTALL_PACKAGE = "slip" |