Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | DESCRIPTION = "Python SQL toolkit and Object Relational Mapper that gives \ |
| 2 | application developers the full power and flexibility of SQL" |
| 3 | HOMEPAGE = "http://www.sqlalchemy.org/" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=f4001d1ca15b69d096fa1b4fd1bdce79" |
| 6 | |
| 7 | SRC_URI[sha256sum] = "6fdd2dc5931daab778c2b65b03df6ae68376e028a3098eb624d0909d999885bc" |
| 8 | |
| 9 | PYPI_PACKAGE = "SQLAlchemy" |
| 10 | inherit pypi setuptools3 |
| 11 | |
| 12 | RDEPENDS:${PN} += " \ |
| 13 | ${PYTHON_PN}-json \ |
| 14 | ${PYTHON_PN}-pickle \ |
| 15 | ${PYTHON_PN}-logging \ |
| 16 | ${PYTHON_PN}-netclient \ |
| 17 | ${PYTHON_PN}-numbers \ |
| 18 | ${PYTHON_PN}-threading \ |
| 19 | ${PYTHON_PN}-compression \ |
| 20 | ${PYTHON_PN}-profile \ |
| 21 | " |
| 22 | |
| 23 | BBCLASSEXTEND = "native nativesdk" |