Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "Lossless data compression library" |
| 2 | HOMEPAGE = "http://www.oberhumer.com/opensource/lzo/" |
| 3 | SECTION = "libs" |
| 4 | LICENSE = "GPLv2+" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| 6 | file://src/lzo_init.c;beginline=5;endline=25;md5=9ae697ca01829b0a383c5d2d163e0108" |
| 7 | |
| 8 | SRC_URI = "http://www.oberhumer.com/opensource/lzo/download/lzo-${PV}.tar.gz \ |
| 9 | file://0001-Use-memcpy-instead-of-reinventing-it.patch \ |
| 10 | file://0001-Add-pkgconfigdir-to-solve-the-undefine-error.patch \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 11 | file://run-ptest \ |
| 12 | " |
| 13 | |
| 14 | SRC_URI[md5sum] = "39d3f3f9c55c87b1e5d6888e1420f4b5" |
| 15 | SRC_URI[sha256sum] = "c0f892943208266f9b6543b3ae308fab6284c5c90e627931446fb49b4221a072" |
| 16 | |
| 17 | inherit autotools ptest |
| 18 | |
| 19 | EXTRA_OECONF = "--enable-shared" |
| 20 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 21 | do_install_ptest() { |
| 22 | t=${D}${PTEST_PATH} |
| 23 | cp ${S}/util/check.sh $t |
| 24 | cp ${B}/minilzo/testmini $t |
| 25 | for i in tests/align tests/chksum lzotest/lzotest examples/simple |
| 26 | do cp ${B}/`dirname $i`/.libs/`basename $i` $t; \ |
| 27 | done |
| 28 | } |
| 29 | |
| 30 | |
| 31 | BBCLASSEXTEND = "native nativesdk" |