Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | # Copyright (C) 2022 Khem Raj <raj.khem@gmail.com> |
| 2 | # Released under the MIT license (see COPYING.MIT for the terms) |
| 3 | |
| 4 | SUMMARY = "API to access the kernel tracefs directory" |
| 5 | HOMEPAGE = "https://git.kernel.org/pub/scm/libs/libtrace/libtracefs.git/" |
| 6 | LICENSE = "GPL-2.0-or-later & LGPL-2.1-or-later" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSES/GPL-2.0;md5=e6a75371ba4d16749254a51215d13f97 \ |
| 8 | file://LICENSES/LGPL-2.1;md5=b370887980db5dd40659b50909238dbd" |
| 9 | SECTION = "libs" |
| 10 | |
| 11 | SRCREV = "826b06bb2484a53fdae196e12ec507a67ec87055" |
| 12 | SRC_URI = "git://git.kernel.org/pub/scm/libs/libtrace/libtraceevent.git;branch=${BPN};protocol=https \ |
| 13 | file://0001-makefile-Do-not-preserve-ownership-in-cp-command.patch" |
| 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
| 17 | inherit pkgconfig |
| 18 | |
| 19 | do_install() { |
| 20 | oe_runmake install DESTDIR=${D} pkgconfig_dir=${libdir}/pkgconfig |
| 21 | } |
| 22 | |
| 23 | PACKAGES += "${PN}-plugins" |
| 24 | |
| 25 | FILES:${PN}-plugins += "${libdir}/traceevent/plugins" |