Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | SUMMARY = "Test::Warn - Perl extension to test methods for warnings" |
| 2 | DESCRIPTION = "This module provides a few convenience methods for testing \ |
| 3 | warning based code. \ |
| 4 | \ |
| 5 | If you are not already familiar with the Test::More manpage now would be \ |
| 6 | the time to go take a look. \ |
| 7 | " |
| 8 | |
| 9 | SECTION = "libs" |
| 10 | HOMEPAGE= "https://metacpan.org/release/Test-Warn" |
| 11 | |
| 12 | LICENSE = "Artistic-1.0 | GPL-1.0-or-later" |
| 13 | LIC_FILES_CHKSUM = "file://README;beginline=73;endline=78;md5=42b423d91c92ba59c215835a2ee9b57a" |
| 14 | |
| 15 | CPAN_PACKAGE = "Test-Warn" |
| 16 | CPAN_AUTHOR = "BIGJ" |
| 17 | |
| 18 | SRC_URI = "${CPAN_MIRROR}/authors/id/B/BI/${CPAN_AUTHOR}/${CPAN_PACKAGE}-${PV}.tar.gz" |
| 19 | |
| 20 | SRC_URI[sha256sum] = "98ca32e7f2f5ea89b8bfb9a0609977f3d153e242e2e51705126cb954f1a06b57" |
| 21 | |
| 22 | S = "${WORKDIR}/${CPAN_PACKAGE}-${PV}" |
| 23 | |
| 24 | inherit cpan ptest-perl |
| 25 | |
| 26 | do_install_ptest() { |
| 27 | cp -r ${B}/blib ${D}${PTEST_PATH} |
| 28 | chown -R root:root ${D}${PTEST_PATH} |
| 29 | } |
| 30 | |
| 31 | RDEPENDS:${PN} += " \ |
| 32 | libsub-uplevel-perl \ |
| 33 | perl-module-blib \ |
| 34 | perl-module-carp \ |
| 35 | perl-module-test-builder \ |
| 36 | perl-module-test-builder-tester \ |
| 37 | perl-module-test-tester \ |
| 38 | " |
| 39 | |
| 40 | RDEPENDS:${PN}-ptest += " \ |
| 41 | perl-module-file-spec \ |
| 42 | perl-module-test-more \ |
| 43 | " |
| 44 | |
| 45 | BBCLASSEXTEND = "native nativesdk" |