Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 1 | SUMMARY = "Real-Time preemption testcases" |
| 2 | HOMEPAGE = "https://rt.wiki.kernel.org/index.php/Cyclictest" |
| 3 | SECTION = "tests" |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 4 | DEPENDS = "linux-libc-headers virtual/libc numactl" |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 5 | LICENSE = "GPLv2 & GPLv2+" |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 7 | |
| 8 | require rt-tests.inc |
| 9 | inherit ptest |
| 10 | |
| 11 | SRC_URI += " \ |
| 12 | file://run-ptest \ |
| 13 | file://rt_bmark.py \ |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 14 | file://0001-Makefile-Allow-for-CC-and-AR-to-be-overridden.patch \ |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 15 | " |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 16 | |
| 17 | # rt-tests needs PI mutex support in libc |
| 18 | COMPATIBLE_HOST_libc-musl = 'null' |
| 19 | |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 20 | # Do not install hwlatdetect |
| 21 | EXTRA_OEMAKE += "PYLIB=''" |
| 22 | |
| 23 | do_install() { |
| 24 | oe_runmake install DESTDIR=${D} SBINDIR=${sbindir} MANDIR=${mandir} \ |
| 25 | INCLUDEDIR=${includedir} |
| 26 | } |
| 27 | |
| 28 | do_install_ptest() { |
| 29 | cp ${WORKDIR}/rt_bmark.py ${D}${PTEST_PATH} |
| 30 | } |
| 31 | |
Brad Bishop | 08902b0 | 2019-08-20 09:16:51 -0400 | [diff] [blame] | 32 | RDEPENDS_${PN}-ptest += " stress-ng python3 python3-multiprocessing python3-datetime python3-misc" |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 33 | |
| 34 | FILES_${PN} += "${prefix}/src/backfire" |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 35 | RDEPENDS_${PN} += "bash" |