blob: c2d644b41759fa076a00224f2d44637ca04b5974 [file] [log] [blame]
Brad Bishopb809eb92019-09-18 06:27:43 -04001SUMMARY = "Crypto and TLS for C++11"
Brad Bishop19323692019-04-05 15:28:33 -04002HOMEPAGE = "https://botan.randombit.net"
3LICENSE = "BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://license.txt;md5=f4c145d4d70a3244a053c9f90d4841fc"
5SECTION = "libs"
6
Brad Bishopb809eb92019-09-18 06:27:43 -04007SRC_URI = "https://botan.randombit.net/releases/Botan-${PV}.tar.xz"
8SRC_URI[md5sum] = "2dba13b0d25d0e9d2a6f9867c62c9f2e"
9SRC_URI[sha256sum] = "f7874da2aeb8c018fd77df40b2137879bf90b66f5589490c991e83fb3e8094be"
Brad Bishop19323692019-04-05 15:28:33 -040010
11S = "${WORKDIR}/Botan-${PV}"
12
13inherit python3native siteinfo lib_package
14
15CPU ?= "${TARGET_ARCH}"
16CPU_x86 = "x86_32"
17CPU_armv7a = "armv7"
18CPU_armv7ve = "armv7"
19
20do_configure() {
21 python3 ${S}/configure.py \
22 --prefix="${D}${prefix}" \
23 --cpu="${CPU}" \
24 --cc-bin="${CXX}" \
25 --cxxflags="${CXXFLAGS}" \
26 --ldflags="${LDFLAGS}" \
27 --with-endian=${@oe.utils.conditional('SITEINFO_ENDIANNESS', 'le', 'little', 'big', d)} \
28 ${@bb.utils.contains("TUNE_FEATURES","neon","","--disable-neon",d)} \
29 --with-sysroot-dir=${STAGING_DIR_TARGET} \
30 --with-build-dir="${B}" \
31 --optimize-for-size \
32 --with-stack-protector \
33 --enable-shared-library \
34 --with-python-versions=3 \
35 ${EXTRA_OECONF}
36}
37
38do_compile() {
39 oe_runmake
40}
41do_install() {
42 oe_runmake install
43 sed -i -e "s|${D}||g" ${D}${libdir}/pkgconfig/botan-2.pc
44}
45
46PACKAGES += "${PN}-python3"
47
48FILES_${PN}-python3 = "${libdir}/python3"
49
50RDEPENDS_${PN}-python3 += "python3"