Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Open Package Manager" |
| 2 | SUMMARY_libopkg = "Open Package Manager library" |
| 3 | SECTION = "base" |
| 4 | HOMEPAGE = "http://code.google.com/p/opkg/" |
| 5 | BUGTRACKER = "http://code.google.com/p/opkg/issues/list" |
| 6 | LICENSE = "GPLv2+" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \ |
| 8 | file://src/opkg.c;beginline=2;endline=21;md5=90435a519c6ea69ef22e4a88bcc52fa0" |
| 9 | |
| 10 | DEPENDS = "libarchive" |
| 11 | |
| 12 | PE = "1" |
| 13 | |
| 14 | SRC_URI = "http://downloads.yoctoproject.org/releases/${BPN}/${BPN}-${PV}.tar.gz \ |
| 15 | file://opkg.conf \ |
| 16 | file://0001-opkg_conf-create-opkg.lock-in-run-instead-of-var-run.patch \ |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 17 | file://run-ptest \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 18 | " |
| 19 | |
Brad Bishop | 96ff198 | 2019-08-19 13:50:42 -0400 | [diff] [blame] | 20 | SRC_URI[md5sum] = "ba0c21305fc93b26e844981ef100dc85" |
| 21 | SRC_URI[sha256sum] = "45ac1e037d3877f635d883f8a555e172883a25d3eeb7986c75890fdd31250a43" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 22 | |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 23 | # This needs to be before ptest inherit, otherwise all ptest files end packaged |
| 24 | # in libopkg package if OPKGLIBDIR == libdir, because default |
| 25 | # PTEST_PATH ?= "${libdir}/${BPN}/ptest" |
| 26 | PACKAGES =+ "libopkg" |
| 27 | |
| 28 | inherit autotools pkgconfig systemd ptest |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 29 | |
| 30 | target_localstatedir := "${localstatedir}" |
Brad Bishop | 96ff198 | 2019-08-19 13:50:42 -0400 | [diff] [blame] | 31 | OPKGLIBDIR ??= "${target_localstatedir}/lib" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 32 | |
| 33 | PACKAGECONFIG ??= "libsolv" |
| 34 | |
| 35 | PACKAGECONFIG[gpg] = "--enable-gpg,--disable-gpg,gpgme libgpg-error,gnupg" |
| 36 | PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl" |
| 37 | PACKAGECONFIG[ssl-curl] = "--enable-ssl-curl,--disable-ssl-curl,curl openssl" |
| 38 | PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl" |
| 39 | PACKAGECONFIG[sha256] = "--enable-sha256,--disable-sha256" |
| 40 | PACKAGECONFIG[pathfinder] = "--enable-pathfinder,--disable-pathfinder,pathfinder" |
| 41 | PACKAGECONFIG[libsolv] = "--with-libsolv,--without-libsolv,libsolv" |
| 42 | |
| 43 | EXTRA_OECONF_class-native = "--localstatedir=/${@os.path.relpath('${localstatedir}', '${STAGING_DIR_NATIVE}')} --sysconfdir=/${@os.path.relpath('${sysconfdir}', '${STAGING_DIR_NATIVE}')}" |
| 44 | |
Brad Bishop | 96ff198 | 2019-08-19 13:50:42 -0400 | [diff] [blame] | 45 | # Release tarball has unused binaries on the tests folder, automatically created by automake. |
| 46 | # For now, delete them to avoid packaging errors (wrong architecture) |
| 47 | do_unpack_append () { |
| 48 | bb.build.exec_func('remove_test_binaries', d) |
| 49 | } |
| 50 | |
| 51 | remove_test_binaries () { |
| 52 | rm ${WORKDIR}/opkg-${PV}/tests/libopkg_test* |
| 53 | } |
| 54 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 55 | do_install_append () { |
| 56 | install -d ${D}${sysconfdir}/opkg |
| 57 | install -m 0644 ${WORKDIR}/opkg.conf ${D}${sysconfdir}/opkg/opkg.conf |
| 58 | echo "option lists_dir ${OPKGLIBDIR}/opkg/lists" >>${D}${sysconfdir}/opkg/opkg.conf |
| 59 | |
| 60 | # We need to create the lock directory |
| 61 | install -d ${D}${OPKGLIBDIR}/opkg |
| 62 | } |
| 63 | |
Brad Bishop | 96ff198 | 2019-08-19 13:50:42 -0400 | [diff] [blame] | 64 | do_install_ptest () { |
| 65 | sed -i -e '/@echo $^/d' ${D}${PTEST_PATH}/tests/Makefile |
| 66 | sed -i -e '/@PYTHONPATH=. $(PYTHON) $^/a\\t@if [ "$$?" != "0" ];then echo "FAIL:"$^;else echo "PASS:"$^;fi' ${D}${PTEST_PATH}/tests/Makefile |
| 67 | } |
| 68 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 69 | RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_update-alternatives} opkg-arch-config libarchive" |
| 70 | RDEPENDS_${PN}_class-native = "" |
| 71 | RDEPENDS_${PN}_class-nativesdk = "" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 72 | RDEPENDS_${PN}-ptest += "make binutils python3-core python3-compression" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 73 | RREPLACES_${PN} = "opkg-nogpg opkg-collateral" |
| 74 | RCONFLICTS_${PN} = "opkg-collateral" |
| 75 | RPROVIDES_${PN} = "opkg-collateral" |
| 76 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 77 | FILES_libopkg = "${libdir}/*.so.* ${OPKGLIBDIR}/opkg/" |
| 78 | |
| 79 | BBCLASSEXTEND = "native nativesdk" |
| 80 | |
| 81 | CONFFILES_${PN} = "${sysconfdir}/opkg/opkg.conf" |