William A. Kennington III via Openembedded-devel | d25baec | 2019-01-15 16:48:56 -0800 | [diff] [blame] | 1 | SUMMARY = "C++11 command line parser" |
| 2 | DESCRIPTION = "A command line parser for C++11 and beyond that provides a rich feature set with a simple and intuitive interface." |
| 3 | HOMEPAGE = "https://github.com/CLIUtils/CLI11" |
| 4 | LICENSE = "BSD-3-Clause" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b73927b18d5c6cd8d2ed28a6ad539733" |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 6 | SRCREV = "5cb3efabce007c3a0230e4cc2e27da491c646b6c" |
William A. Kennington III via Openembedded-devel | d25baec | 2019-01-15 16:48:56 -0800 | [diff] [blame] | 7 | PV .= "+git${SRCPV}" |
| 8 | |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 9 | SRC_URI += "gitsm://github.com/CLIUtils/CLI11;branch=v1" |
William A. Kennington III via Openembedded-devel | d25baec | 2019-01-15 16:48:56 -0800 | [diff] [blame] | 10 | |
| 11 | S = "${WORKDIR}/git" |
| 12 | |
| 13 | inherit cmake |
| 14 | inherit ptest |
| 15 | |
Brad Bishop | 90ca747 | 2019-08-20 09:15:15 -0400 | [diff] [blame] | 16 | # cli11 is a header only C++ library, so the main package will be empty. |
| 17 | RDEPENDS_${PN}-dev = "" |