Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 1 | # Class to test UBOOT_MKIMAGE and UBOOT_MKIMAGE_SIGN |
2 | # (in conjunction with kernel-fitimage.bbclass) | ||||
3 | # | ||||
4 | # SPDX-License-Identifier: MIT | ||||
5 | # | ||||
6 | |||||
7 | UBOOT_MKIMAGE = "test_mkimage_wrapper" | ||||
8 | UBOOT_MKIMAGE_SIGN = "test_mkimage_signing_wrapper" | ||||
9 | |||||
10 | test_mkimage_wrapper() { | ||||
11 | echo "### uboot-mkimage wrapper message" | ||||
12 | uboot-mkimage "$@" | ||||
13 | } | ||||
14 | |||||
15 | test_mkimage_signing_wrapper() { | ||||
16 | echo "### uboot-mkimage signing wrapper message" | ||||
17 | uboot-mkimage "$@" | ||||
18 | } | ||||
19 |