Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "A C implementation of the Constrained Application Protocol" |
| 2 | DESCRIPTION = "libcoap implements a lightweight application-protocol for \ |
| 3 | devices that are constrained their resources such as computing power, \ |
| 4 | RF range, memory, bandwith, or network packet sizes." |
| 5 | HOMEPAGE ="https://libcoap.net/" |
| 6 | |
| 7 | LICENSE = "BSD-2-Clause & BSD-3-Clause" |
| 8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=1978dbc41673ab1c20e64b287c8317bc" |
| 9 | |
| 10 | SRC_URI = "git://github.com/obgm/libcoap.git;branch=main;protocol=https \ |
| 11 | file://run-ptest \ |
| 12 | " |
| 13 | SRCREV = "5fd2f89ef068214130e5d60b7087ef48711fa615" |
| 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
| 17 | inherit autotools manpages pkgconfig ptest |
| 18 | |
| 19 | DEPENDS += "ctags-native" |
| 20 | |
| 21 | PACKAGECONFIG ?= "\ |
| 22 | async openssl tcp \ |
| 23 | ${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)} \ |
| 24 | " |
| 25 | PACKAGECONFIG[async] = "--enable-async,--disable-async" |
| 26 | PACKAGECONFIG[gnutls] = "--with-gnutls,--without-gnutls,gnutls,,,openssl mbedtls" |
| 27 | PACKAGECONFIG[manpages] = "--enable-documentation --enable-doxygen --enable-manpages,--disable-documentation,asciidoc-native doxygen-native graphviz-native" |
| 28 | PACKAGECONFIG[mbedtls] = "--with-mbedtls,--without-mbedtls,mbedtls,,,gnutls openssl" |
| 29 | PACKAGECONFIG[openssl] = "--with-openssl,--without-openssl,openssl,,,gnutls mbedtls" |
| 30 | PACKAGECONFIG[small-stack] = "--enable-small-stack,--disable-small-stack" |
| 31 | PACKAGECONFIG[tcp] = "--enable-tcp,--disable-tcp" |
| 32 | PACKAGECONFIG[tests] = "--enable-tests,--disable-tests,cunit" |
| 33 | |
| 34 | EXTRA_OECONF = "\ |
| 35 | --with-epoll --enable-add-default-names \ |
| 36 | --without-tinydtls --without-submodule-tinydtls \ |
| 37 | ${@bb.utils.contains_any('PACKAGECONFIG', 'gnutls openssl mbedtls', '--enable-dtls', '--disable-dtls', d)} \ |
| 38 | " |
| 39 | |
| 40 | python () { |
| 41 | if d.getVar('PTEST_ENABLED') == "1": |
| 42 | d.setVar('DISABLE_STATIC', '') |
| 43 | } |
| 44 | |
| 45 | export SGML_CATALOG_FILES="file://${STAGING_ETCDIR_NATIVE}/xml/catalog" |
| 46 | |
| 47 | do_compile:prepend() { |
| 48 | oe_runmake update-map-file |
| 49 | } |
| 50 | |
| 51 | do_install_ptest () { |
| 52 | install -d ${D}${PTEST_PATH} |
| 53 | install -m 0755 ${WORKDIR}/run-ptest ${D}${PTEST_PATH}/run-ptest |
| 54 | install -m 0755 ${B}/tests/testdriver ${D}${PTEST_PATH}/testdriver |
| 55 | } |
| 56 | |
| 57 | PACKAGE_BEFORE_PN += "\ |
| 58 | ${PN}-bin \ |
| 59 | " |
| 60 | |
| 61 | FILES:${PN}-bin = "${bindir}" |
| 62 | FILES:${PN}-dev += "${datadir}/${BPN}/examples" |