blob: d57cb977e4415e9d9b2ef51e624210050427f4f3 [file] [log] [blame]
William A. Kennington IIIb95905d2021-06-02 12:40:56 -07001SUMMARY = "Network scanning and manipulation tool"
2DESCRIPTION = "Scapy is a powerful interactive packet manipulation program. \
3It is able to forge or decode packets of a wide number of protocols, send \
4them on the wire, capture them, match requests and replies, and much more. \
5It can easily handle most classical tasks like scanning, tracerouting, probing, \
6unit tests, attacks or network discovery (it can replace hping, 85% of nmap, \
7arpspoof, arp-sk, arping, tcpdump, tethereal, p0f, etc.). It also performs very \
8well at a lot of other specific tasks that most other tools can't handle, like \
9sending invalid frames, injecting your own 802.11 frames, combining technics \
10(VLAN hopping+ARP cache poisoning, VOIP decoding on WEP encrypted channel, ...), etc."
11SECTION = "security"
Andrew Geissler9aee5002022-03-30 16:27:02 +000012LICENSE = "GPL-2.0-only"
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070013
14LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
15
16# If you want ptest support, use the git repo
17# UTscapy does not exist in the pypi pkg
18#
Patrick Williamsac13d5f2023-11-24 18:59:46 -060019SRCREV = "0474c37bf1d147c969173d52ab3ac76d2404d981"
Andrew Geissler595f6302022-01-24 19:11:47 +000020SRC_URI = "git://github.com/secdev/scapy.git;branch=master;protocol=https \
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070021 file://run-ptest"
22
23S = "${WORKDIR}/git"
24
25UPSTREAM_CHECK_COMMITS = "1"
26
27inherit setuptools3 ptest
28
Patrick Williams213cb262021-08-07 19:21:33 -050029do_install:append() {
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070030 mv ${D}${bindir}/scapy ${D}${bindir}/scapy3
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070031}
32
33do_install_ptest() {
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060034 install -m 0644 ${S}/scapy/tools/UTscapy.py ${D}${PTEST_PATH}
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070035 install -m 0644 ${S}/test/regression.uts ${D}${PTEST_PATH}
36 sed -i 's,@PTEST_PATH@,${PTEST_PATH},' ${D}${PTEST_PATH}/run-ptest
37}
38
Patrick Williams39653562024-03-01 08:54:02 -060039RDEPENDS:${PN} = "tcpdump python3-compression python3-cryptography python3-netclient \
40 python3-netserver python3-pydoc python3-pkgutil python3-shell \
41 python3-threading python3-numbers python3-fcntl python3-logging \
42 python3-difflib"
43RDEPENDS:${PN}-ptest += "python3-json python3-mock python3-multiprocessing \
44 iproute2 tshark"