Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | DESCRIPTION = "A small tool to provide detailed information on the hardware \ |
| 2 | configuration of the machine. It can report exact memory configuration, \ |
| 3 | firmware version, mainboard configuration, CPU version and speed, cache \ |
| 4 | configuration, bus speed, etc. on DMI-capable or EFI systems." |
| 5 | SUMMARY = "Hardware lister" |
| 6 | HOMEPAGE = "http://ezix.org/project/wiki/HardwareLiSter" |
| 7 | SECTION = "console/tools" |
| 8 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 9 | LICENSE = "GPL-2.0-or-later" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 11 | |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 12 | COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64|riscv64).*-linux" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 13 | |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 14 | PV .= "+git" |
| 15 | SRCREV = "4c6497c8b0a67cd9fa9693e9101a7cafd3297e81" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 16 | SRC_URI = " \ |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 17 | git://github.com/lyonel/lshw.git;protocol=https;branch=master \ |
| 18 | file://0001-disable-docbook2man.patch \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 19 | " |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 20 | |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 21 | S = "${WORKDIR}/git" |
| 22 | |
| 23 | inherit pkgconfig |
| 24 | |
| 25 | DEPENDS = "gettext-native" |
| 26 | |
| 27 | PACKAGECONFIG ??= "zlib" |
| 28 | PACKAGECONFIG[sqlite] = "SQLITE=1,SQLITE=0,sqlite3" |
| 29 | PACKAGECONFIG[zlib] = "ZLIB=1,ZLIB=0,zlib gzip-native" |
| 30 | |
| 31 | # use the PACKAGECONFIG configurations arguments |
Patrick Williams | b542dec | 2023-06-09 01:26:37 -0500 | [diff] [blame] | 32 | EXTRA_OEMAKE = "${PACKAGECONFIG_CONFARGS} RPM_OPT_FLAGS='${CFLAGS}'" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 33 | |
| 34 | do_compile() { |
| 35 | # build core only - don't ship gui |
| 36 | oe_runmake -C src core |
| 37 | } |
| 38 | |
| 39 | do_install() { |
| 40 | oe_runmake install DESTDIR=${D} |
| 41 | } |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 42 | |
| 43 | BBCLASSEXTEND = "native" |