blob: 36e46021bbebb4e258bb68beeec148152c89cd24 [file] [log] [blame]
Brad Bishop6a62e0e2019-10-21 08:11:42 -04001SUMMARY = "fifo maps for c++"
2HOMEPAGE = "https://github.com/nlohmann/fifo_map"
3SECTION = "libs"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.MIT;md5=b67209a1e36b682a8226de19d265b1e0"
6
Andrew Geissler595f6302022-01-24 19:11:47 +00007SRC_URI = "git://github.com/nlohmann/fifo_map.git;branch=master;protocol=https"
Brad Bishop6a62e0e2019-10-21 08:11:42 -04008
Patrick Williams73bd93f2024-02-20 08:07:48 -06009PV = "1.0.0+git"
Brad Bishop6a62e0e2019-10-21 08:11:42 -040010
Andrew Geissler87f5cff2022-09-30 13:13:31 -050011SRCREV = "d732aaf9a315415ae8fd7eb11e3a4c1f80e42a48"
Brad Bishop6a62e0e2019-10-21 08:11:42 -040012
Andrew Geissler82c905d2020-04-13 13:39:40 -050013UPSTREAM_CHECK_COMMITS = "1"
14
Brad Bishop6a62e0e2019-10-21 08:11:42 -040015S = "${WORKDIR}/git"
16
17# nlohmann-fifo is a header only C++ library, so the main package will be empty.
18
Patrick Williams213cb262021-08-07 19:21:33 -050019RDEPENDS:${PN}-dev = ""
Brad Bishop6a62e0e2019-10-21 08:11:42 -040020
21BBCLASSEXTEND = "native nativesdk"
22
Andrew Geissler87f5cff2022-09-30 13:13:31 -050023# See https://github.com/SOCI/soci/issues/984
24CXXFLAGS:append:toolchain-clang:runtime-llvm = " -DCATCH_CONFIG_CPP11_NO_SHUFFLE"
25
Brad Bishop6a62e0e2019-10-21 08:11:42 -040026do_install() {
27 install -d ${D}${includedir}
28 install -m 0644 ${S}/src/fifo_map.hpp ${D}${includedir}
29}