Patrick Williams | 03514f1 | 2024-04-05 07:04:11 -0500 | [diff] [blame] | 1 | SUMMARY = "Convert WSGI app to ASGI app or ASGI app to WSGI app." |
| 2 | HOMEPAGE = "https://github.com/abersheeran/a2wsgi" |
| 3 | LICENSE = "Apache-2.0" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e10d05d29ec6d8be8bfc503683f1bc9a" |
| 5 | |
| 6 | inherit pypi python_setuptools_build_meta ptest |
| 7 | |
| 8 | SRC_URI[sha256sum] = "50e81ac55aa609fa2c666e42bacc25c424c8884ce6072f1a7e902114b7ee5d63" |
| 9 | |
| 10 | DEPENDS += " \ |
| 11 | python3-pdm-native \ |
| 12 | python3-pdm-backend-native \ |
| 13 | " |
| 14 | |
| 15 | SRC_URI += " \ |
| 16 | file://run-ptest \ |
| 17 | " |
| 18 | |
| 19 | RDEPENDS:${PN}-ptest += " \ |
| 20 | python3-httpx \ |
| 21 | python3-pytest \ |
| 22 | python3-pytest-asyncio \ |
| 23 | python3-unittest-automake-output \ |
| 24 | " |
| 25 | |
| 26 | do_install_ptest() { |
| 27 | install -d ${D}${PTEST_PATH}/tests |
| 28 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 29 | } |
| 30 | |
| 31 | RDEPENDS:${PN} += " \ |
| 32 | python3-asyncio \ |
| 33 | " |