blob: 13e31afe798f20bfea54f6b8b1fb55c0d8d3cdd7 [file] [log] [blame]
Patrick Williams73bd93f2024-02-20 08:07:48 -06001DESCRIPTION = "DNS toolkit for Python"
2HOMEPAGE = "http://www.dnspython.org/"
3LICENSE = "ISC"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=5af50906b5929837f667dfe31052bd34"
5
Patrick Williams03514f12024-04-05 07:04:11 -05006SRC_URI[sha256sum] = "e8f0f9c23a7b7cb99ded64e6c3a6f3e701d78f50c55e002b839dea7225cff7cc"
Patrick Williams73bd93f2024-02-20 08:07:48 -06007
8inherit pypi python_hatchling ptest
9
10SRC_URI += " \
11 file://run-ptest \
12"
13
14RDEPENDS:${PN}-ptest += " \
15 python3-pytest \
16 python3-unittest-automake-output \
17"
18
19do_install_ptest() {
20 install -d ${D}${PTEST_PATH}/tests
21 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
22}
23
24DEPENDS += "\
25 python3-wheel-native \
26 python3-setuptools-scm-native \
27"
28
29RDEPENDS:${PN} += " \
30 python3-crypt \
31 python3-io \
32 python3-math \
33 python3-netclient \
34 python3-numbers \
35 python3-threading \
36"