Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | DESCRIPTION = "Google gRPC tools" |
| 2 | HOMEPAGE = "http://www.grpc.io/" |
| 3 | SECTION = "devel/python" |
| 4 | |
| 5 | LICENSE = "Apache-2.0" |
| 6 | LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=7145f7cdd263359b62d342a02f005515" |
| 7 | |
| 8 | inherit pypi setuptools3 |
| 9 | |
Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 10 | DEPENDS += "python3-grpcio" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 11 | |
| 12 | SRC_URI += "file://0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch \ |
| 13 | file://0001-protobuf-Disable-musttail-attribute-on-mips.patch \ |
| 14 | " |
Patrick Williams | 03514f1 | 2024-04-05 07:04:11 -0500 | [diff] [blame] | 15 | SRC_URI[sha256sum] = "a4991e5ee8a97ab791296d3bf7e8700b1445635cc1828cc98df945ca1802d7f2" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 16 | |
Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 17 | RDEPENDS:${PN} = "python3-grpcio" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 18 | |
| 19 | BBCLASSEXTEND = "native nativesdk" |