blob: 202d4c3eb8b9239ffc7977cf79c9ab5da1db81ae [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Implementation of a fully functional filesystem in a userspace program"
2DESCRIPTION = "FUSE (Filesystem in Userspace) is a simple interface for userspace \
3 programs to export a virtual filesystem to the Linux kernel. FUSE \
4 also aims to provide a secure method for non privileged users to \
5 create and mount their own filesystem implementations. \
6 "
7HOMEPAGE = "https://github.com/libfuse/libfuse"
8SECTION = "libs"
9LICENSE = "GPLv2 & LGPLv2"
10LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
11 file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
12
13SRC_URI = "https://github.com/libfuse/libfuse/releases/download/${BP}/${BP}.tar.gz \
14 file://gold-unversioned-symbol.patch \
15 file://aarch64.patch \
16 file://0001-fuse-fix-the-return-value-of-help-option.patch \
17 file://fuse.conf \
18"
19SRC_URI[md5sum] = "9bd4ce8184745fd3d000ca2692adacdb"
20SRC_URI[sha256sum] = "832432d1ad4f833c20e13b57cf40ce5277a9d33e483205fc63c78111b3358874"
21
22inherit autotools pkgconfig update-rc.d systemd
23
24INITSCRIPT_NAME = "fuse"
25INITSCRIPT_PARAMS = "start 3 S . stop 20 0 6 ."
26
27SYSTEMD_SERVICE_${PN} = ""
28
29DEPENDS = "gettext-native"
30
31PACKAGES =+ "fuse-utils-dbg fuse-utils libulockmgr libulockmgr-dev libulockmgr-dbg"
32
33RRECOMMENDS_${PN}_class-target = "kernel-module-fuse libulockmgr fuse-utils"
34
35FILES_${PN} += "${libdir}/libfuse.so.*"
36FILES_${PN}-dev += "${libdir}/libfuse*.la"
37
38FILES_libulockmgr = "${libdir}/libulockmgr.so.*"
39FILES_libulockmgr-dev += "${libdir}/libulock*.la"
40FILES_libulockmgr-dbg += "${libdir}/.debug/libulock*"
41
42# Forbid auto-renaming to libfuse-utils
43FILES_fuse-utils = "${bindir} ${base_sbindir}"
44FILES_fuse-utils-dbg = "${bindir}/.debug ${base_sbindir}/.debug"
45DEBIAN_NOAUTONAME_fuse-utils = "1"
46DEBIAN_NOAUTONAME_fuse-utils-dbg = "1"
47
48do_configure_prepend() {
49 # Make this explicit so overriding base_sbindir propagates properly.
50 export MOUNT_FUSE_PATH="${base_sbindir}"
51}
52
53do_install_append() {
54 rm -rf ${D}${base_prefix}/dev
55
56 # systemd class remove the sysv_initddir only if systemd_system_unitdir
57 # contains anything, but it's not needed if sysvinit is not in DISTRO_FEATURES
58 if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'false', 'true', d)}; then
59 rm -rf ${D}${sysconfdir}/init.d/
60 fi
61
62 # Install systemd related configuration file
63 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
64 install -d ${D}${sysconfdir}/modules-load.d
65 install -m 0644 ${WORKDIR}/fuse.conf ${D}${sysconfdir}/modules-load.d
66 fi
67}
68
69BBCLASSEXTEND = "native nativesdk"