Andrew Geissler | 7f40b71 | 2020-05-15 14:09:53 -0500 | [diff] [blame] | 1 | SUMMARY = "Full-featured IRC plugin: multi-servers, proxy support, IPv6, SASL authentication, nicklist, DCC, and many other features" |
| 2 | HOMEPAE = "https://weechat.org/" |
| 3 | SECTION = "net" |
| 4 | LICENSE = "GPLv3" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=c678957b0c8e964aa6c70fd77641a71e" |
| 6 | |
| 7 | DEPENDS = "openssl zlib icu libgcrypt gnutls curl aspell" |
| 8 | |
| 9 | SRC_URI = "https://weechat.org/files/src/weechat-${PV}.tar.xz \ |
| 10 | file://0001-use-pkg-config-for-gcrypt-instead.patch \ |
| 11 | " |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 12 | |
Andrew Geissler | 4b7c115 | 2020-11-30 19:55:29 -0600 | [diff] [blame] | 13 | SRC_URI[sha256sum] = "6cb7d25a363b66b835f1b9f29f3580d6f09ac7d38505b46a62c178b618d9f1fb" |
Andrew Geissler | 7f40b71 | 2020-05-15 14:09:53 -0500 | [diff] [blame] | 14 | |
| 15 | inherit cmake pkgconfig |
| 16 | |
| 17 | PACKAGECONFIG ??= " ncurses python" |
| 18 | PACKAGECONFIG[ncurses] = "-DENABLE_NCURSES=ON,-DENABLE_NCURSES=OFF,ncurses" |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 19 | PACKAGECONFIG[python] = "-DENABLE_PYTHON=ON,-DENABLE_PYTHON=OFF,python3,python3" |
Andrew Geissler | 7f40b71 | 2020-05-15 14:09:53 -0500 | [diff] [blame] | 20 | |
| 21 | EXTRA_OECMAKE_append = " -DENABLE_PHP=OFF -DENABLE_TCL=OFF -DENABLE_LUA=OFF -DENABLE_JAVASCRIPT=OFF -DENABLE_RUBY=OFF -DENABLE_GUILE=OFF -DENABLE_PERL=OFF -DENABLE_ASPELL=ON" |
| 22 | |
| 23 | do_configure_prepend(){ |
| 24 | # Make sure we get dependencies from recipe-sysroot |
| 25 | sed -i -e 's# /usr/bin# ${RECIPE_SYSROOT}/${bindir}/#g' ${S}/cmake/FindPerl.cmake |
| 26 | sed -i -e 's# /usr/local/bin##g' ${S}/cmake/FindPerl.cmake |
| 27 | sed -i -e 's# /usr/pkg/bin##g' ${S}/cmake/FindPerl.cmake |
| 28 | } |
| 29 | |
| 30 | do_install_append(){ |
| 31 | rm -rf ${D}/${datadir} |
| 32 | } |
| 33 | |