Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Tools for managing memory technology devices" |
| 2 | HOMEPAGE = "http://www.linux-mtd.infradead.org/" |
| 3 | SECTION = "base" |
| 4 | LICENSE = "GPLv2+" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \ |
| 6 | file://include/common.h;beginline=1;endline=17;md5=ba05b07912a44ea2bf81ce409380049c" |
| 7 | |
| 8 | DEPENDS = "zlib lzo e2fsprogs util-linux" |
| 9 | |
| 10 | PV = "1.5.1+git${SRCPV}" |
| 11 | |
| 12 | SRCREV = "9f107132a6a073cce37434ca9cda6917dd8d866b" |
| 13 | SRC_URI = "git://git.infradead.org/mtd-utils.git \ |
| 14 | file://add-exclusion-to-mkfs-jffs2-git-2.patch \ |
| 15 | file://fix-armv7-neon-alignment.patch \ |
| 16 | file://0001-hashtable-Remove-duplicate-hashtable_iterator_value-.patch \ |
| 17 | file://mtd-utils-fix-corrupt-cleanmarker-with-flash_erase--j-command.patch \ |
| 18 | " |
| 19 | |
| 20 | S = "${WORKDIR}/git/" |
| 21 | |
| 22 | # xattr support creates an additional compile-time dependency on acl because |
| 23 | # the sys/acl.h header is needed. libacl is not needed and thus enabling xattr |
| 24 | # regardless whether acl is enabled or disabled in the distro should be okay. |
| 25 | PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'xattr', 'xattr', '', d)}" |
| 26 | PACKAGECONFIG[xattr] = ",,acl," |
| 27 | |
| 28 | EXTRA_OEMAKE = "'CC=${CC}' 'RANLIB=${RANLIB}' 'AR=${AR}' 'CFLAGS=${CFLAGS} ${@bb.utils.contains('PACKAGECONFIG', 'xattr', '', '-DWITHOUT_XATTR', d)} -I${S}/include' 'BUILDDIR=${S}'" |
| 29 | |
| 30 | do_install () { |
| 31 | oe_runmake install DESTDIR=${D} SBINDIR=${sbindir} MANDIR=${mandir} INCLUDEDIR=${includedir} |
| 32 | } |
| 33 | |
| 34 | PACKAGES =+ "mtd-utils-jffs2 mtd-utils-ubifs mtd-utils-misc" |
| 35 | |
| 36 | FILES_mtd-utils-jffs2 = "${sbindir}/mkfs.jffs2 ${sbindir}/jffs2dump ${sbindir}/jffs2reader ${sbindir}/sumtool" |
| 37 | FILES_mtd-utils-ubifs = "${sbindir}/mkfs.ubifs ${sbindir}/ubi*" |
| 38 | FILES_mtd-utils-misc = "${sbindir}/nftl* ${sbindir}/ftl* ${sbindir}/rfd* ${sbindir}/doc* ${sbindir}/serve_image ${sbindir}/recv_image" |
| 39 | |
| 40 | BBCLASSEXTEND = "native" |
| 41 | |
| 42 | # git/.compr.c.dep:46: warning: NUL character seen; rest of line ignored |
| 43 | # git/.compr.c.dep:47: *** missing separator. Stop. |
| 44 | PARALLEL_MAKE = "" |