Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Python bindings for the DBus inter-process communication system" |
| 2 | SECTION = "devel/python" |
| 3 | HOMEPAGE = "http://www.freedesktop.org/Software/dbus" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=0b83047ce9e948b67c0facc5f233476a" |
| 6 | DEPENDS = "expat dbus dbus-glib virtual/libintl python-pyrex-native" |
| 7 | |
| 8 | SRC_URI = "http://dbus.freedesktop.org/releases/dbus-python/dbus-python-${PV}.tar.gz \ |
| 9 | " |
| 10 | |
| 11 | SRC_URI[md5sum] = "b09cd2d1a057cc432ce944de3fc06bf7" |
| 12 | SRC_URI[sha256sum] = "e12c6c8b2bf3a9302f75166952cbe41d6b38c3441bbc6767dbd498942316c6df" |
| 13 | S = "${WORKDIR}/dbus-python-${PV}" |
| 14 | |
| 15 | inherit distutils-base autotools pkgconfig |
| 16 | |
| 17 | PACKAGECONFIG ?= "" |
| 18 | PACKAGECONFIG[docs] = "--enable-html-docs,--disable-html-docs,python-docutils-native" |
| 19 | PACKAGECONFIG[api-docs] = "--enable-api-docs,--disable-api-docs,python-docutils-native python-epydoc-native" |
| 20 | |
| 21 | export BUILD_SYS |
| 22 | export HOST_SYS |
| 23 | |
| 24 | export STAGING_LIBDIR |
| 25 | export STAGING_INCDIR |
| 26 | |
| 27 | RDEPENDS_${PN} = "python-io python-logging python-stringold python-threading python-xml" |
| 28 | |
| 29 | FILES_${PN}-dev += "${libdir}/pkgconfig" |