Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Wayland, a protocol between a compositor and clients" |
| 2 | DESCRIPTION = "Wayland is a protocol for a compositor to talk to its clients \ |
| 3 | as well as a C library implementation of that protocol. The compositor can be \ |
| 4 | a standalone display server running on Linux kernel modesetting and evdev \ |
| 5 | input devices, an X application, or a wayland client itself. The clients can \ |
| 6 | be traditional applications, X servers (rootless or fullscreen) or other \ |
| 7 | display servers." |
| 8 | HOMEPAGE = "http://wayland.freedesktop.org" |
| 9 | LICENSE = "MIT" |
| 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=b31d8f53b6aaf2b4985d7dd7810a70d1 \ |
| 11 | file://src/wayland-server.c;endline=24;md5=b8e046164a766bb1ede8ba38e9dcd7ce" |
| 12 | |
| 13 | DEPENDS = "expat libxml2 libffi wayland-native" |
| 14 | |
| 15 | SRC_URI = "https://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \ |
| 16 | file://fixpathinpcfiles.patch \ |
| 17 | " |
| 18 | SRC_URI[md5sum] = "d91f970aea11fd549eae023d06f91af3" |
| 19 | SRC_URI[sha256sum] = "72aa11b8ac6e22f4777302c9251e8fec7655dc22f9d94ee676c6b276f95f91a4" |
| 20 | |
| 21 | UPSTREAM_CHECK_URI = "https://wayland.freedesktop.org/releases.html" |
| 22 | |
| 23 | inherit autotools pkgconfig |
| 24 | |
| 25 | EXTRA_OECONF = "--disable-documentation --with-host-scanner" |
| 26 | EXTRA_OECONF_class-native = "--disable-documentation --disable-libraries" |
| 27 | |
| 28 | # Wayland installs a M4 macro for other projects to use, which uses the target |
| 29 | # pkg-config to find files. Replace pkg-config with pkg-config-native. |
| 30 | do_install_append_class-native() { |
| 31 | sed -e 's,PKG_CHECK_MODULES(.*),,g' \ |
| 32 | -e 's,$PKG_CONFIG,pkg-config-native,g' \ |
| 33 | -i ${D}/${datadir}/aclocal/wayland-scanner.m4 |
| 34 | } |
| 35 | |
| 36 | sysroot_stage_all_append_class-target () { |
| 37 | rm ${SYSROOT_DESTDIR}/${datadir}/aclocal/wayland-scanner.m4 |
| 38 | cp ${STAGING_DATADIR_NATIVE}/aclocal/wayland-scanner.m4 ${SYSROOT_DESTDIR}/${datadir}/aclocal/ |
| 39 | } |
| 40 | |
| 41 | FILES_${PN} = "${libdir}/*${SOLIBS}" |
| 42 | FILES_${PN}-dev += "${bindir} ${datadir}/wayland" |
| 43 | |
| 44 | BBCLASSEXTEND = "native nativesdk" |