blob: bf5c52fe504816c9cc399ad7707aa22dc58918c7 [file] [log] [blame]
Andrew Geissler6aa7eec2023-03-03 12:41:14 -06001SUMMARY = "smemstat reports the physical memory usage taking into consideration shared memory"
2HOMEPAGE = "https://github.com/ColinIanKing/smemstat"
3LICENSE = "GPL-2.0-or-later"
4
5LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
6
7DEPENDS = "ncurses"
8
9SRC_URI = "git://github.com/ColinIanKing/smemstat.git;protocol=https;branch=master"
Patrick Williams73bd93f2024-02-20 08:07:48 -060010SRCREV = "1edc560602aa116b96408110b8b9d66a4edef60e"
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060011
12S = "${WORKDIR}/git"
13
14inherit bash-completion
15
16do_compile () {
17 oe_runmake smemstat
18}
19
20do_install () {
21 oe_runmake DESTDIR=${D} install
22}