Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | require automake.inc |
| 2 | LICENSE = "GPLv2" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" |
| 4 | DEPENDS_class-native = "autoconf-native" |
| 5 | |
| 6 | NAMEVER = "${@oe.utils.trim_version("${PV}", 2)}" |
| 7 | |
| 8 | RDEPENDS_${PN} += "\ |
| 9 | autoconf \ |
| 10 | perl \ |
| 11 | perl-module-bytes \ |
| 12 | perl-module-data-dumper \ |
| 13 | perl-module-strict \ |
| 14 | perl-module-text-parsewords \ |
| 15 | perl-module-thread-queue \ |
| 16 | perl-module-threads \ |
| 17 | perl-module-vars " |
| 18 | |
| 19 | RDEPENDS_${PN}_class-native = "autoconf-native hostperl-runtime-native" |
| 20 | RDEPENDS_${PN}_class-nativesdk = "nativesdk-autoconf" |
| 21 | |
| 22 | SRC_URI += "file://python-libdir.patch \ |
| 23 | file://buildtest.patch \ |
| 24 | file://performance.patch \ |
| 25 | file://new_rt_path_for_test-driver.patch \ |
| 26 | file://automake-replace-w-option-in-shebangs-with-modern-use-warnings.patch \ |
| 27 | file://0001-automake-Add-default-libtool_tag-to-cppasm.patch \ |
| 28 | " |
| 29 | |
| 30 | SRC_URI[md5sum] = "95df3f2d6eb8f81e70b8cb63a93c8853" |
| 31 | SRC_URI[sha256sum] = "988e32527abe052307d21c8ca000aa238b914df363a617e38f4fb89f5abf6260" |
| 32 | |
| 33 | PERL = "${USRBINPATH}/perl" |
| 34 | PERL_class-native = "${USRBINPATH}/env perl" |
| 35 | PERL_class-nativesdk = "${USRBINPATH}/env perl" |
| 36 | |
| 37 | CACHED_CONFIGUREVARS += "ac_cv_path_PERL='${PERL}'" |
| 38 | |
| 39 | do_install_append () { |
| 40 | install -d ${D}${datadir} |
| 41 | } |
| 42 | |
| 43 | BBCLASSEXTEND = "native nativesdk" |