Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | DESCRIPTION = "Thumbnail service implementing the thumbnail management D-Bus specification" |
| 2 | SECTION = "x11/libs" |
| 3 | LICENSE = "GPL-2.0-or-later" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 5 | DEPENDS = "freetype gdk-pixbuf poppler curl xfce4-dev-tools-native libxml2 libgsf libxfce4util" |
| 6 | |
| 7 | inherit xfce gtk-doc systemd |
| 8 | |
| 9 | SRC_URI[sha256sum] = "4087f3af4ef31271d3f315421a2f1fe67e4fda7ad60bbab1f073627914dfcf00" |
| 10 | |
| 11 | INSANE_SKIP:${PN} = "dev-so" |
| 12 | |
| 13 | PACKAGECONFIG ??= "" |
| 14 | PACKAGECONFIG[gstreamer-thumbnailer] = "--enable-gstreamer-thumbnailer,--disable-gstreamer-thumbnailer,gstreamer1.0 gstreamer1.0-plugins-base" |
| 15 | |
| 16 | do_install:append() { |
| 17 | # Makefile seems to race on creation of symlink. So ensure creation here |
| 18 | # until fixed properly |
| 19 | ln -sf tumbler-xdg-cache.so ${D}${libdir}/tumbler-1/plugins/cache/tumbler-cache-plugin.so |
| 20 | } |
| 21 | |
| 22 | FILES:${PN} += "${datadir}/dbus-1/services \ |
| 23 | ${libdir}/tumbler-1/tumblerd \ |
| 24 | ${libdir}/tumbler-1/plugins/*.so \ |
| 25 | ${libdir}/tumbler-1/plugins/cache/*.so \ |
| 26 | ${systemd_user_unitdir}/tumblerd.service \ |
| 27 | " |
| 28 | |
| 29 | FILES:${PN}-dev += "${libdir}/tumbler-1/plugins/*.la \ |
| 30 | ${libdir}/tumbler-1/plugins/cache/*.la \ |
| 31 | " |