Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 1 | SUMMARY = "Real-Time preemption testcases" |
| 2 | HOMEPAGE = "https://rt.wiki.kernel.org/index.php/Cyclictest" |
| 3 | SECTION = "tests" |
| 4 | DEPENDS = "linux-libc-headers virtual/libc" |
| 5 | LICENSE = "GPLv2 & GPLv2+" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \ |
| 7 | file://src/cyclictest/cyclictest.c;beginline=7;endline=9;md5=e768b8da44555fe63f65e5c497844cb5 \ |
| 8 | file://src/pi_tests/pi_stress.c;beginline=6;endline=19;md5=bd426a634a43ec612e9fbf125dfcc949" |
| 9 | |
| 10 | require rt-tests.inc |
| 11 | inherit ptest |
| 12 | |
| 13 | SRC_URI += " \ |
| 14 | file://run-ptest \ |
| 15 | file://rt_bmark.py \ |
| 16 | " |
| 17 | # Do not install hwlatdetect |
| 18 | EXTRA_OEMAKE += "PYLIB=''" |
| 19 | |
| 20 | do_install() { |
| 21 | oe_runmake install DESTDIR=${D} SBINDIR=${sbindir} MANDIR=${mandir} \ |
| 22 | INCLUDEDIR=${includedir} |
| 23 | } |
| 24 | |
| 25 | do_install_ptest() { |
| 26 | cp ${WORKDIR}/rt_bmark.py ${D}${PTEST_PATH} |
| 27 | } |
| 28 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 29 | RDEPENDS_${PN}-ptest += " stress python3 python3-multiprocessing python3-datetime python3-misc" |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 30 | |
| 31 | FILES_${PN} += "${prefix}/src/backfire" |