Andrew Geissler | cc58928 | 2020-09-18 13:34:40 -0500 | [diff] [blame] | 1 | SUMMARY = "IBM's Software TPM 2.0" |
| 2 | DESCRIPTION = "The software TPM 2.0 is targeted toward application development, \ |
| 3 | education, and virtualization. \ |
| 4 | \ |
| 5 | The intent is that an application can be developed using the software TPM. \ |
| 6 | The application should then run using a hardware TPM without changes. \ |
| 7 | Advantages of this approach: \ |
| 8 | * In contrast to a hardware TPM, it runs on many platforms and it's generally faster. \ |
| 9 | * Application software errors are easily reversed by simply removing the TPM state and starting over. \ |
| 10 | * Difficult crypto errors are quickly debugged by looking inside the TPM." |
| 11 | HOMEPAGE = "http://ibmswtpm.sourceforge.net/ibmswtpm2.html" |
| 12 | LICENSE = "BSD" |
| 13 | SECTION = "securty/tpm" |
| 14 | LIC_FILES_CHKSUM = "file://../LICENSE;md5=1e023f61454ac828b4aa1bc4293f7d5f" |
| 15 | |
| 16 | DEPENDS = "openssl" |
| 17 | |
| 18 | SRC_URI = "https://sourceforge.net/projects/ibmswtpm2/files/ibmtpm${PV}.tar.gz \ |
| 19 | file://tune-makefile.patch \ |
Andrew Geissler | cc58928 | 2020-09-18 13:34:40 -0500 | [diff] [blame] | 20 | " |
William A. Kennington III | ee32beb | 2021-06-02 12:48:35 -0700 | [diff] [blame^] | 21 | |
| 22 | SRC_URI[sha256sum] = "55145928ad2b24f34be6a0eacf9fb492e10e0ea919b8428c721fa970e85d6147" |
| 23 | |
| 24 | UPSTREAM_CHECK_REGEX = "libtpm(?P<pver>).tar.gz" |
Andrew Geissler | cc58928 | 2020-09-18 13:34:40 -0500 | [diff] [blame] | 25 | |
| 26 | S = "${WORKDIR}/src" |
| 27 | |
Andrew Geissler | 8b13928 | 2021-03-05 15:22:30 -0600 | [diff] [blame] | 28 | CFLAGS += "-Wno-error=maybe-uninitialized -DALG_CAMELLIA=ALG_NO" |
Andrew Geissler | cc58928 | 2020-09-18 13:34:40 -0500 | [diff] [blame] | 29 | |
| 30 | do_compile () { |
| 31 | make CC='${CC}' |
| 32 | } |
| 33 | |
| 34 | do_install () { |
| 35 | install -d ${D}/${bindir} |
| 36 | install -m 0755 tpm_server ${D}/${bindir} |
| 37 | } |