Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 1 | SUMMARY = "Simple powerful testing with python" |
Andrew Geissler | 95ac1b8 | 2021-03-31 14:34:31 -0500 | [diff] [blame] | 2 | HOMEPAGE = "https://pypi.org/project/pytest/" |
| 3 | DESCRIPTION = "The pytest framework makes it easy to write small tests, yet scales to support complex functional testing for applications and libraries." |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 4 | |
| 5 | LICENSE = "MIT" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=81eb9f71d006c6b268cf4388e3c98f7b" |
| 7 | |
| 8 | SRC_URI_append = " file://0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch " |
| 9 | |
Andrew Geissler | 9b4d8b0 | 2021-02-19 12:26:16 -0600 | [diff] [blame] | 10 | SRC_URI[sha256sum] = "9d1edf9e7d0b84d72ea3dbcdfd22b35fb543a5e8f2a60092dd578936bf63d7f9" |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 11 | |
| 12 | inherit update-alternatives pypi setuptools3 |
| 13 | |
| 14 | RDEPENDS_${PN}_class-target += " \ |
| 15 | ${PYTHON_PN}-atomicwrites \ |
| 16 | ${PYTHON_PN}-attrs \ |
| 17 | ${PYTHON_PN}-debugger \ |
| 18 | ${PYTHON_PN}-doctest \ |
| 19 | ${PYTHON_PN}-importlib-metadata \ |
| 20 | ${PYTHON_PN}-iniconfig \ |
| 21 | ${PYTHON_PN}-json \ |
| 22 | ${PYTHON_PN}-more-itertools \ |
| 23 | ${PYTHON_PN}-packaging \ |
| 24 | ${PYTHON_PN}-pathlib2 \ |
| 25 | ${PYTHON_PN}-pluggy \ |
| 26 | ${PYTHON_PN}-py \ |
| 27 | ${PYTHON_PN}-setuptools \ |
| 28 | ${PYTHON_PN}-six \ |
| 29 | ${PYTHON_PN}-toml \ |
| 30 | ${PYTHON_PN}-wcwidth \ |
| 31 | " |
| 32 | |
| 33 | ALTERNATIVE_${PN} += "py.test pytest" |
| 34 | |
| 35 | NATIVE_LINK_NAME[pytest] = "${bindir}/pytest" |
| 36 | ALTERNATIVE_TARGET[pytest] = "${bindir}/pytest" |
| 37 | |
| 38 | ALTERNATIVE_LINK_NAME[py.test] = "${bindir}/py.test" |
| 39 | ALTERNATIVE_TARGET[py.test] = "${bindir}/py.test" |
| 40 | |
| 41 | BBCLASSEXTEND = "native nativesdk" |