Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "mcelog daemon accounts memory and some other errors in various ways." |
| 2 | DESCRIPTION = "mcelog is required by both 32bit x86 Linux kernels (since 2.6.30) \ |
| 3 | and 64bit Linux kernels (since early 2.6 kernel releases) to log machine checks \ |
| 4 | and should run on all Linux systems that need error handling." |
| 5 | HOMEPAGE = "http://mcelog.org/" |
| 6 | SECTION = "System Environment/Base" |
| 7 | |
| 8 | SRC_URI = "git://git.kernel.org/pub/scm/utils/cpu/mce/mcelog.git;protocol=http; \ |
Andrew Geissler | eef6386 | 2021-01-29 15:58:13 -0600 | [diff] [blame^] | 9 | file://0001-test-avoid-the-pfa-test-hang.patch \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 10 | file://run-ptest \ |
| 11 | " |
| 12 | |
Andrew Geissler | eafcbb8 | 2020-06-05 17:59:17 -0500 | [diff] [blame] | 13 | SRCREV = "391abaac9bdff385934b18134789bcc98b0adeb7" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 14 | |
| 15 | LICENSE = "GPLv2" |
| 16 | LIC_FILES_CHKSUM = "file://README.md;md5=74bb47b9a68850cb398665cf78b31de6" |
| 17 | |
| 18 | S = "${WORKDIR}/git" |
| 19 | |
| 20 | inherit autotools-brokensep ptest |
| 21 | |
| 22 | COMPATIBLE_HOST = '(x86_64.*|i.86.*)-linux' |
| 23 | |
| 24 | do_install_append() { |
| 25 | install -d ${D}${sysconfdir}/cron.hourly |
| 26 | install -m 0755 ${S}/mcelog.cron ${D}${sysconfdir}/cron.hourly/ |
| 27 | sed -i 's/bash/sh/' ${D}${sysconfdir}/cron.hourly/mcelog.cron |
| 28 | } |
| 29 | |
| 30 | do_install_ptest() { |
| 31 | install -d ${D}${PTEST_PATH} |
| 32 | cp -r ${S}/tests ${S}/input ${D}${PTEST_PATH} |
| 33 | sed -i 's#../../mcelog#mcelog#' ${D}${PTEST_PATH}/tests/test |
| 34 | } |
| 35 | |
| 36 | RDEPENDS_${PN}-ptest += "make bash mce-inject" |