Benjamin Fair | fbf258a | 2019-10-21 18:45:41 -0700 | [diff] [blame] | 1 | SUMMARY = "Image Generation and Programming Scripts for NPCM7XX (Poleg) devices" |
| 2 | DESCRIPTION = "Image Generation and Programming Scripts for NPCM7XX (Poleg) devices" |
| 3 | HOMEPAGE = "https://github.com/Nuvoton-Israel/igps" |
| 4 | LICENSE = "GPLv2" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 6 | |
| 7 | SRC_URI = " \ |
| 8 | git://github.com/Nuvoton-Israel/igps \ |
| 9 | file://0001-Adjust-paths-for-use-with-Bitbake.patch \ |
| 10 | " |
| 11 | # tag IGPS_02.01.12 |
| 12 | SRCREV = "2fb1a3b0d61164ed1157e27889a4ec2292cbc760" |
| 13 | |
| 14 | S = "${WORKDIR}/git" |
| 15 | |
| 16 | DEST = "${D}${datadir}/${BPN}" |
| 17 | |
| 18 | do_install() { |
| 19 | install -d ${DEST} |
| 20 | install ImageGeneration/references/BootBlockAndHeader_${IGPS_MACHINE}.xml ${DEST} |
| 21 | install ImageGeneration/references/UbootHeader_${IGPS_MACHINE}.xml ${DEST} |
| 22 | install ImageGeneration/inputs/mergedBootBlockAndUboot.xml ${DEST} |
| 23 | } |
| 24 | |
| 25 | inherit native |