Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | # TODO: include debian's mtp-tools man page (needs xsltproc-native and |
| 2 | # docbook-xsl-native, or we pregenerate it), add support for doxygen |
| 3 | # generation fully with -natives |
| 4 | DESCRIPTION = "libmtp is an Initiator implementation of the Media Transfer \ |
| 5 | Protocol (MTP) in the form of a library suitable primarily for POSIX \ |
| 6 | compliant operating systems" |
| 7 | SUMMARY = "libmtp is an Initiator implementation of the Media Transfer Protocol (MTP)" |
| 8 | HOMEPAGE = "http://libmtp.sourceforge.net/" |
| 9 | LICENSE = "LGPL-2.1+" |
| 10 | LIC_FILES_CHKSUM = "\ |
| 11 | file://COPYING;md5=0448d3676bc0de00406af227d341a4d1 \ |
| 12 | file://src/ptp.c;beginline=3;endline=22;md5=303cc4422fd549ef8689aded20434a9a \ |
| 13 | file://examples/albums.c;beginline=5;endline=21;md5=84f4e55dfec49e898b7f68a828c15620 \ |
| 14 | " |
| 15 | |
| 16 | BBCLASSEXTEND = "native" |
| 17 | |
| 18 | DEPENDS = "libusb1 gettext-native" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 19 | DEPENDS:append:class-target = " ${BPN}-native" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 20 | |
| 21 | SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BPN}-${PV}.tar.gz" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 22 | SRC_URI:append:class-target = " file://0001-Use-native-mtp-hotplug.patch" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 23 | |
Andrew Geissler | bbbd5f4 | 2020-10-30 15:42:48 -0500 | [diff] [blame] | 24 | SRC_URI[md5sum] = "7915496daa3f4ea3e095f0161f83d4d4" |
| 25 | SRC_URI[sha256sum] = "7280fe50c044c818a06667f45eabca884deab3193caa8682e0b581e847a281f0" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 26 | |
| 27 | inherit autotools pkgconfig lib_package |
| 28 | |
| 29 | EXTRA_OECONF += " \ |
| 30 | --disable-rpath \ |
| 31 | --with-udev=${nonarch_base_libdir}/udev \ |
| 32 | " |
| 33 | |
| 34 | PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'largefile', d)}" |
| 35 | PACKAGECONFIG[doxygen] = "--enable-doxygen,--disable-doxygen" |
| 36 | PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile" |
| 37 | PACKAGECONFIG[mtpz] = "--enable-mtpz,--disable-mtpz,libgcrypt" |
| 38 | |
| 39 | PACKAGES =+ "${BPN}-common ${BPN}-runtime" |
| 40 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 41 | RDEPENDS:${BPN} += "libmtp-common" |
| 42 | RRECOMMENDS:${BPN} += "libmtp-runtime ${PN}-bin" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 43 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 44 | FILES:${BPN}-common = "${nonarch_base_libdir}/udev/rules.d/*" |
| 45 | SUMMARY:${BPN}-common = "The udev rules file for MTP devices" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 46 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 47 | FILES:${BPN}-runtime = "${nonarch_base_libdir}/udev/mtp-probe" |
| 48 | RDEPENDS:${BPN}-runtime = "libmtp-common" |
| 49 | SUMMARY:${BPN}-runtime = "mtp-probe, used for the MTP udev rules" |
| 50 | DESCRIPTION:${BPN}-runtime = "This package provides mtp-probe, a program to probe newly connected device interfaces from userspace to determine if they are MTP devices, used for udev rules." |