Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame^] | 1 | SUMMARY = "PolicyKit Authorization Framework" |
| 2 | DESCRIPTION = "The polkit package is an application-level toolkit for defining and handling the policy that allows unprivileged processes to speak to privileged processes." |
| 3 | HOMEPAGE = "http://www.freedesktop.org/wiki/Software/polkit" |
| 4 | LICENSE = "LGPLv2+" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=155db86cdbafa7532b41f390409283eb \ |
| 6 | file://src/polkit/polkit.h;beginline=1;endline=20;md5=0a8630b0133176d0504c87a0ded39db4" |
| 7 | |
| 8 | DEPENDS = "expat glib-2.0 intltool-native mozjs" |
| 9 | |
| 10 | inherit autotools gtk-doc pkgconfig useradd systemd gobject-introspection features_check |
| 11 | |
| 12 | REQUIRED_DISTRO_FEATURES = "polkit" |
| 13 | |
| 14 | PACKAGECONFIG = "${@bb.utils.filter('DISTRO_FEATURES', 'pam', d)} \ |
| 15 | ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', \ |
| 16 | bb.utils.contains('DISTRO_FEATURES', 'x11', 'consolekit', '', d), d)} \ |
| 17 | " |
| 18 | |
| 19 | PACKAGECONFIG[pam] = "--with-authfw=pam,--with-authfw=shadow,libpam,libpam" |
| 20 | PACKAGECONFIG[systemd] = "--enable-libsystemd-login=yes --with-systemdsystemunitdir=${systemd_unitdir}/system/,--enable-libsystemd-login=no --with-systemdsystemunitdir=,systemd" |
| 21 | # there is no --enable/--disable option for consolekit and it's not picked by shlibs, so add it to RDEPENDS |
| 22 | PACKAGECONFIG[consolekit] = ",,,consolekit" |
| 23 | |
| 24 | PAM_SRC_URI = "file://polkit-1_pam.patch" |
| 25 | SRC_URI = "http://www.freedesktop.org/software/polkit/releases/polkit-${PV}.tar.gz \ |
| 26 | ${@bb.utils.contains('DISTRO_FEATURES', 'pam', '${PAM_SRC_URI}', '', d)} \ |
| 27 | file://0003-make-netgroup-support-optional.patch \ |
| 28 | file://0002-jsauthority-port-to-mozjs-91.patch \ |
| 29 | file://0003-jsauthority-ensure-to-call-JS_Init-and-JS_ShutDown-e.patch \ |
| 30 | " |
| 31 | SRC_URI[sha256sum] = "c8579fdb86e94295404211285fee0722ad04893f0213e571bd75c00972fd1f5c" |
| 32 | |
| 33 | EXTRA_OECONF = "--with-os-type=moblin \ |
| 34 | --disable-man-pages \ |
| 35 | --disable-libelogind \ |
| 36 | " |
| 37 | |
| 38 | do_compile:prepend () { |
| 39 | export GIR_EXTRA_LIBS_PATH="${B}/src/polkit/.libs" |
| 40 | } |
| 41 | |
| 42 | PACKAGES =+ "${PN}-examples" |
| 43 | |
| 44 | FILES:${PN}:append = " \ |
| 45 | ${libdir}/${BPN}-1 \ |
| 46 | ${nonarch_libdir}/${BPN}-1 \ |
| 47 | ${datadir}/dbus-1 \ |
| 48 | ${datadir}/${BPN}-1 \ |
| 49 | ${datadir}/gettext \ |
| 50 | " |
| 51 | |
| 52 | FILES:${PN}-examples = "${bindir}/*example*" |
| 53 | |
| 54 | USERADD_PACKAGES = "${PN}" |
| 55 | USERADD_PARAM:${PN} = "--system --no-create-home --user-group --home-dir ${sysconfdir}/${BPN}-1 polkitd" |
| 56 | |
| 57 | SYSTEMD_SERVICE:${PN} = "${BPN}.service" |
| 58 | SYSTEMD_AUTO_ENABLE = "disable" |