Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame^] | 1 | SUMMARY = "Crypt Openssl RSA cpan module" |
| 2 | SECTION = "libs" |
| 3 | LICENSE = "Artistic-1.0 | GPL-1.0+" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=a67ceecc5d9a91a5a0d003ba50c26346" |
| 5 | |
| 6 | SRC_URI = "http://www.cpan.org/modules/by-module/Crypt/Crypt-OpenSSL-RSA-${PV}.tar.gz \ |
| 7 | file://0001-Fix-for-Issue-31.patch \ |
| 8 | " |
| 9 | |
| 10 | SRC_URI[sha256sum] = "adc74f0ae125c77f65d5dd32abb9c3429300a79543bf263494f333f9c0b62a61" |
| 11 | |
| 12 | DEPENDS += "libcrypt-openssl-guess-perl-native openssl" |
| 13 | |
| 14 | RDEPENDS:${PN} = " \ |
| 15 | libcrypt-openssl-random-perl \ |
| 16 | perl-module-autoloader \ |
| 17 | perl-module-carp \ |
| 18 | perl-module-strict \ |
| 19 | perl-module-warnings \ |
| 20 | perl-module-xsloader \ |
| 21 | " |
| 22 | |
| 23 | EXTRA_CPANFLAGS = "INC='-I${STAGING_INCDIR}' LIBS='-L${STAGING_LIBDIR} -lssl -L${STAGING_DIR_TARGET}${base_libdir} -lcrypto'" |
| 24 | |
| 25 | S = "${WORKDIR}/Crypt-OpenSSL-RSA-${PV}" |
| 26 | |
| 27 | inherit cpan ptest-perl |
| 28 | |
| 29 | do_compile() { |
| 30 | export OTHERLDFLAGS='-Wl,-rpath' |
| 31 | cpan_do_compile |
| 32 | } |
| 33 | |
| 34 | RDEPENDS:${PN}-ptest = " \ |
| 35 | ${PN} \ |
| 36 | perl-module-file-copy \ |
| 37 | perl-module-test \ |
| 38 | perl-module-test-more \ |
| 39 | " |