Andrew Geissler | 89770b0 | 2020-06-13 10:40:47 -0500 | [diff] [blame] | 1 | SUMMARY = "Extensions to the standard Python datetime module" |
| 2 | DESCRIPTION = "The dateutil module provides powerful extensions to the datetime module available in the Python standard library." |
| 3 | HOMEPAGE = "https://dateutil.readthedocs.org" |
| 4 | LICENSE = "BSD-3-Clause & Apache-2.0" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e3155c7bdc71f66e02678411d2abf996" |
| 6 | |
Andrew Geissler | 6972109 | 2021-07-23 12:57:00 -0400 | [diff] [blame] | 7 | SRC_URI[sha256sum] = "0123cacc1627ae19ddf3c27a5de5bd67ee4586fbdd6440d9748f8abb483d3e86" |
Andrew Geissler | 89770b0 | 2020-06-13 10:40:47 -0500 | [diff] [blame] | 8 | |
| 9 | PYPI_PACKAGE = "python-dateutil" |
| 10 | inherit pypi setuptools3 |
| 11 | |
| 12 | PACKAGES =+ "${PN}-zoneinfo" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 13 | FILES:${PN}-zoneinfo = "${libdir}/${PYTHON_DIR}/site-packages/dateutil/zoneinfo" |
Andrew Geissler | 89770b0 | 2020-06-13 10:40:47 -0500 | [diff] [blame] | 14 | |
| 15 | DEPENDS += "${PYTHON_PN}-setuptools-scm-native" |
| 16 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 17 | RDEPENDS:${PN} = "\ |
Andrew Geissler | 89770b0 | 2020-06-13 10:40:47 -0500 | [diff] [blame] | 18 | ${PYTHON_PN}-datetime \ |
| 19 | ${PYTHON_PN}-numbers \ |
| 20 | ${PYTHON_PN}-six \ |
| 21 | ${PYTHON_PN}-stringold \ |
| 22 | " |
| 23 | |
Andrew Geissler | a2681d9 | 2020-10-16 10:17:07 -0500 | [diff] [blame] | 24 | BBCLASSEXTEND = "native nativesdk" |