Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "A coroutine-based Python networking library" |
| 2 | DESCRIPTION = "gevent is a coroutine-based Python networking library that uses greenlet to provide \ |
| 3 | a high-level synchronous API on top of the libevent event loop." |
| 4 | HOMEPAGE = "http://www.gevent.org" |
| 5 | LICENSE = "MIT & Python-2.0 & BSD" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=4de99aac27b470c29c6c309e0c279b65 \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 7 | file://NOTICE;md5=18108df3583462cafd457f024b9b09b5 \ |
| 8 | file://deps/libev/LICENSE;md5=d6ad416afd040c90698edcdf1cbee347 \ |
| 9 | " |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 10 | DEPENDS += "libevent" |
| 11 | DEPENDS += "${PYTHON_PN}-greenlet" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 12 | RDEPENDS:${PN} = "${PYTHON_PN}-greenlet \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 13 | ${PYTHON_PN}-mime \ |
| 14 | ${PYTHON_PN}-pprint \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 15 | " |
| 16 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 17 | FILESEXTRAPATHS:prepend := "${THISDIR}/python-gevent:" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 18 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 19 | SRC_URI:append = " \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 20 | file://libev-conf.patch;patch=1;pnum=1 \ |
| 21 | " |
| 22 | |
Andrew Geissler | d159c7f | 2021-09-02 21:05:58 -0500 | [diff] [blame] | 23 | SRC_URI[sha256sum] = "43e93e1a4738c922a2416baf33f0afb0a20b22d3dba886720bc037cd02a98575" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 24 | |
| 25 | # The python-gevent has no autoreconf ability |
| 26 | # and the logic for detecting a cross compile is flawed |
| 27 | # so always force a cross compile |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 28 | do_configure:append() { |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 29 | sed -i -e 's/^cross_compiling=no/cross_compiling=yes/' ${S}/deps/libev/configure |
| 30 | sed -i -e 's/^cross_compiling=no/cross_compiling=yes/' ${S}/deps/c-ares/configure |
| 31 | } |
| 32 | |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 33 | inherit pypi setuptools3 |