Richard Marian Thomaiyar | 14fddef | 2018-07-13 23:55:56 +0530 | [diff] [blame] | 1 | SUMMARY = "low-level tool handling Linux filesystem encryption" |
| 2 | DESCIPTION = "fscryptctl is a low-level tool written in C that handles raw keys and manages \ |
| 3 | policies for Linux filesystem encryption (https://lwn.net/Articles/639427). \ |
| 4 | For a tool that presents a higher level interface and manages metadata, key \ |
| 5 | generation, key wrapping, PAM integration, and passphrase hashing, see \ |
| 6 | fscrypt (https://github.com/google/fscrypt)." |
| 7 | HOMEPAGE = "https://github.com/google/fscryptctl" |
| 8 | SECTION = "base" |
| 9 | LICENSE = "Apache-2.0" |
| 10 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" |
| 11 | |
Andrew Geissler | 8b13928 | 2021-03-05 15:22:30 -0600 | [diff] [blame] | 12 | SRCREV = "56b898c896240328adef7407090215abbe9ee03d" |
Patrick Williams | 53961c2 | 2022-01-20 11:06:23 -0600 | [diff] [blame] | 13 | SRC_URI = "git://github.com/google/fscryptctl.git;branch=master;protocol=https" |
Richard Marian Thomaiyar | 14fddef | 2018-07-13 23:55:56 +0530 | [diff] [blame] | 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
| 17 | do_install() { |
Andrew Geissler | 9d3cc05 | 2021-03-31 13:36:22 -0500 | [diff] [blame] | 18 | oe_runmake DESTDIR=${D} PREFIX=/usr install |
Richard Marian Thomaiyar | 14fddef | 2018-07-13 23:55:56 +0530 | [diff] [blame] | 19 | } |
| 20 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 21 | RRECOMMENDS:${PN} += "\ |
Richard Marian Thomaiyar | 14fddef | 2018-07-13 23:55:56 +0530 | [diff] [blame] | 22 | keyutils \ |
| 23 | kernel-module-cbc \ |
| 24 | kernel-module-cts \ |
| 25 | kernel-module-ecb \ |
| 26 | kernel-module-xts \ |
| 27 | " |