Richard Marian Thomaiyar | 14fddef | 2018-07-13 23:55:56 +0530 | [diff] [blame] | 1 | SUMMARY = "redhat security tools" |
| 2 | DESCRIPTION = "Tools used by redhat linux distribution for security checks" |
| 3 | SECTION = "security" |
| 4 | LICENSE = "GPLv2" |
Andrew Geissler | 8b13928 | 2021-03-05 15:22:30 -0600 | [diff] [blame] | 5 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0-only;md5=801f80980d171dd6425610833a22dbe6" |
Richard Marian Thomaiyar | 14fddef | 2018-07-13 23:55:56 +0530 | [diff] [blame] | 6 | |
| 7 | SRC_URI = "file://find-chroot-py.sh \ |
| 8 | file://find-chroot.sh \ |
| 9 | file://find-elf4tmp.sh \ |
| 10 | file://find-execstack.sh \ |
| 11 | file://find-hidden-exec.sh \ |
| 12 | file://find-nodrop-groups.sh \ |
| 13 | file://find-sh4errors.sh \ |
| 14 | file://find-sh4tmp.sh \ |
| 15 | file://lib-bin-check.sh \ |
| 16 | file://rpm-chksec.sh \ |
| 17 | file://rpm-drop-groups.sh \ |
| 18 | file://selinux-check-devices.sh \ |
| 19 | file://selinux-ls-unconfined.sh" |
| 20 | |
| 21 | S = "${WORKDIR}" |
| 22 | |
| 23 | do_install() { |
| 24 | install -d ${D}${bindir} |
| 25 | install -m 0755 ${WORKDIR}/find-chroot-py.sh ${D}${bindir} |
| 26 | install -m 0755 ${WORKDIR}/find-chroot.sh ${D}${bindir} |
| 27 | install -m 0755 ${WORKDIR}/find-elf4tmp.sh ${D}${bindir} |
| 28 | install -m 0755 ${WORKDIR}/find-execstack.sh ${D}${bindir} |
| 29 | install -m 0755 ${WORKDIR}/find-hidden-exec.sh ${D}${bindir} |
| 30 | install -m 0755 ${WORKDIR}/find-nodrop-groups.sh ${D}${bindir} |
| 31 | install -m 0755 ${WORKDIR}/find-sh4errors.sh ${D}${bindir} |
| 32 | install -m 0755 ${WORKDIR}/find-sh4tmp.sh ${D}${bindir} |
| 33 | install -m 0755 ${WORKDIR}/lib-bin-check.sh ${D}${bindir} |
| 34 | install -m 0755 ${WORKDIR}/rpm-chksec.sh ${D}${bindir} |
| 35 | install -m 0755 ${WORKDIR}/rpm-drop-groups.sh ${D}${bindir} |
| 36 | install -m 0755 ${WORKDIR}/selinux-check-devices.sh ${D}${bindir} |
| 37 | install -m 0755 ${WORKDIR}/selinux-ls-unconfined.sh ${D}${bindir} |
| 38 | } |
| 39 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 40 | RDEPENDS:${PN} = "file libcap-ng procps findutils" |