Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame^] | 1 | SUMMARY = "Program for creating simple man pages" |
| 2 | HOMEPAGE = "https://www.gnu.org/software/help2man/" |
| 3 | DESCRIPTION = "help2man is a tool for automatically generating simple manual pages from program output." |
| 4 | SECTION = "devel" |
| 5 | LICENSE = "GPLv3" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464" |
| 7 | |
| 8 | SRC_URI = "${GNU_MIRROR}/${BPN}/${BPN}-${PV}.tar.xz" |
| 9 | SRC_URI[sha256sum] = "6739e4caa42e6aed3399be4387ca79399640967334e91728863b8eaa922582be" |
| 10 | |
| 11 | inherit autotools |
| 12 | |
| 13 | # This is a hand-maintained aclocal.m4 but our autotools class currently deletes |
| 14 | # aclocal.m4. |
| 15 | EXTRA_AUTORECONF += "--exclude=aclocal" |
| 16 | |
| 17 | EXTRA_OECONF = "--disable-nls" |
| 18 | |
| 19 | do_install:append () { |
| 20 | # Make sure we use /usr/bin/env perl |
| 21 | sed -i -e "1s:#!.*:#! /usr/bin/env perl:" ${D}${bindir}/help2man |
| 22 | } |
| 23 | |
| 24 | BBCLASSEXTEND = "native nativesdk" |