Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame^] | 1 | SUMMARY = "Framework for layout and rendering of internationalized text" |
| 2 | DESCRIPTION = "Pango is a library for laying out and rendering of text, \ |
| 3 | with an emphasis on internationalization. Pango can be used anywhere \ |
| 4 | that text layout is needed, though most of the work on Pango so far has \ |
| 5 | been done in the context of the GTK+ widget toolkit. Pango forms the \ |
| 6 | core of text and font handling for GTK+-2.x." |
| 7 | HOMEPAGE = "http://www.pango.org/" |
| 8 | BUGTRACKER = "http://bugzilla.gnome.org" |
| 9 | SECTION = "libs" |
| 10 | LICENSE = "LGPLv2.0+" |
| 11 | |
| 12 | LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7" |
| 13 | |
| 14 | GNOMEBASEBUILDCLASS = "meson" |
| 15 | |
| 16 | inherit gnomebase gi-docgen ptest-gnome upstream-version-is-even gobject-introspection |
| 17 | |
| 18 | GIR_MESON_ENABLE_FLAG = "enabled" |
| 19 | GIR_MESON_DISABLE_FLAG = "disabled" |
| 20 | |
| 21 | SRC_URI += "file://run-ptest" |
| 22 | |
| 23 | SRC_URI[archive.sha256sum] = "21e1f5798bcdfda75eabc4280514b0896ab56f656d4e7e66030b9a2535ecdc98" |
| 24 | |
| 25 | DEPENDS = "glib-2.0 glib-2.0-native fontconfig freetype virtual/libiconv cairo harfbuzz fribidi" |
| 26 | |
| 27 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)} \ |
| 28 | ${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)}" |
| 29 | |
| 30 | PACKAGECONFIG[x11] = ",,virtual/libx11 libxft" |
| 31 | PACKAGECONFIG[tests] = "-Dinstall-tests=true, -Dinstall-tests=false" |
| 32 | PACKAGECONFIG[thai] = ",,libthai" |
| 33 | |
| 34 | GIR_MESON_OPTION = 'introspection' |
| 35 | |
| 36 | do_configure:prepend() { |
| 37 | chmod +x ${S}/tests/*.py |
| 38 | } |
| 39 | |
| 40 | do_configure:prepend:toolchain-clang() { |
| 41 | sed -i -e "/Werror=implicit-fallthrough/d" ${S}/meson.build |
| 42 | } |
| 43 | |
| 44 | LEAD_SONAME = "libpango-1.0*" |
| 45 | |
| 46 | FILES:${PN} = "${bindir}/* ${libdir}/libpango*${SOLIBS}" |
| 47 | |
| 48 | RDEPENDS:${PN}-ptest += "cantarell-fonts" |
| 49 | RDEPENDS:${PN}-ptest:append:libc-glibc = " locale-base-en-us" |
| 50 | |
| 51 | RPROVIDES:${PN} += "pango-modules pango-module-indic-lang \ |
| 52 | pango-module-basic-fc pango-module-arabic-lang" |
| 53 | |
| 54 | BBCLASSEXTEND = "native nativesdk" |