blob: 42dcbda25e41c920ec9db01c0e59f97d18f51aee [file] [log] [blame]
Jie Yang7fe1bad2021-08-06 12:41:16 -07001SUMMARY = "GLOME Login Client"
2DESCRIPTION = "GLOME login is first application of the GLOME protocol. It is used to authorize serial console access to Linux machines"
3PR = "r1"
4PV = "0.1+git${SRCPV}"
5
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
8
9inherit meson pkgconfig
10
William A. Kennington III9c5d7fa2022-07-08 14:39:13 -070011DEPENDS += "openssl"
Jie Yang7fe1bad2021-08-06 12:41:16 -070012
13S = "${WORKDIR}/git"
Patrick Williamsbb99d222022-01-24 15:55:09 -060014SRC_URI = "git://github.com/google/glome.git;branch=master;protocol=https"
William A. Kennington III9c5d7fa2022-07-08 14:39:13 -070015SRCREV = "978ad9fb165f1e382c875f2ce08a1fc4f2ddcf1b"
Jie Yang7fe1bad2021-08-06 12:41:16 -070016
17FILES_${PN} += "${libdir}/security"
18
19PACKAGECONFIG ??= ""
20PACKAGECONFIG[glome-cli] = "-Dglome-cli=true,-Dglome-cli=false"
21PACKAGECONFIG[pam-glome] = "-Dpam-glome=true,-Dpam-glome=false,libpam"
22
William A. Kennington III9c5d7fa2022-07-08 14:39:13 -070023EXTRA_OEMESON = "-Dtests=false"