Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "File classification tool" |
| 2 | DESCRIPTION = "File attempts to classify files depending \ |
| 3 | on their contents and prints a description if a match is found." |
| 4 | HOMEPAGE = "http://www.darwinsys.com/file/" |
| 5 | SECTION = "console/utils" |
| 6 | |
| 7 | # two clause BSD |
| 8 | LICENSE = "BSD" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;beginline=2;md5=6a7382872edb68d33e1a9398b6e03188" |
| 10 | |
Patrick Williams | f1e5d69 | 2016-03-30 15:21:19 -0500 | [diff] [blame^] | 11 | DEPENDS = "zlib file-replacement-native" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 12 | DEPENDS_class-native = "zlib-native" |
| 13 | |
| 14 | SRC_URI = "git://github.com/file/file.git \ |
| 15 | file://debian-742262.patch \ |
| 16 | file://0001-Add-P-prompt-into-Usage-info.patch \ |
Patrick Williams | f1e5d69 | 2016-03-30 15:21:19 -0500 | [diff] [blame^] | 17 | file://host-file.patch \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 18 | " |
| 19 | |
| 20 | SRCREV = "3c0874be4d3232d672b20f513451a39cfd7c585a" |
| 21 | S = "${WORKDIR}/git" |
| 22 | |
| 23 | inherit autotools |
| 24 | |
Patrick Williams | f1e5d69 | 2016-03-30 15:21:19 -0500 | [diff] [blame^] | 25 | EXTRA_OEMAKE_append_class-target = "-e FILE_COMPILE=${STAGING_BINDIR_NATIVE}/file-native/file" |
| 26 | EXTRA_OEMAKE_append_class-nativesdk = "-e FILE_COMPILE=${STAGING_BINDIR_NATIVE}/file-native/file" |
| 27 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 28 | FILES_${PN} += "${datadir}/misc/*.mgc" |
| 29 | |
| 30 | do_install_append_class-native() { |
| 31 | create_cmdline_wrapper ${D}/${bindir}/file \ |
| 32 | --magic-file ${datadir}/misc/magic.mgc |
| 33 | } |
| 34 | |
| 35 | do_install_append_class-nativesdk() { |
| 36 | create_cmdline_wrapper ${D}/${bindir}/file \ |
| 37 | --magic-file ${datadir}/misc/magic.mgc |
| 38 | } |
| 39 | |
| 40 | BBCLASSEXTEND = "native nativesdk" |
Patrick Williams | f1e5d69 | 2016-03-30 15:21:19 -0500 | [diff] [blame^] | 41 | PROVIDES_append_class-native = " file-replacement-native" |
| 42 | # Don't use NATIVE_PACKAGE_PATH_SUFFIX as that hides libmagic from anyone who |
| 43 | # depends on file-replacement-native. |
| 44 | bindir_append_class-native = "/file-native" |