Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "SysV init scripts which are only used in an LSB image" |
| 2 | SECTION = "base" |
| 3 | LICENSE = "GPLv2" |
| 4 | DEPENDS = "popt glib-2.0" |
| 5 | |
Patrick Williams | f1e5d69 | 2016-03-30 15:21:19 -0500 | [diff] [blame^] | 6 | RDEPENDS_${PN} += "util-linux" |
| 7 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=ebf4e8b49780ab187d51bd26aaa022c6" |
| 9 | |
| 10 | S="${WORKDIR}/initscripts-${PV}" |
| 11 | SRC_URI = "http://pkgs.fedoraproject.org/repo/pkgs/initscripts/initscripts-${PV}.tar.bz2/9cce2ae1009750e84be37c09a028757e/initscripts-${PV}.tar.bz2 \ |
| 12 | file://functions.patch \ |
| 13 | file://0001-functions-avoid-exit-1-which-causes-init-scripts-to-.patch \ |
| 14 | " |
| 15 | |
| 16 | SRC_URI[md5sum] = "9cce2ae1009750e84be37c09a028757e" |
| 17 | SRC_URI[sha256sum] = "48b59ce8157cfc58bbd4b1dfa58ad1087245761ae11c2033b66ae3864ea7e1cf" |
| 18 | |
| 19 | inherit update-alternatives |
| 20 | |
| 21 | ALTERNATIVE_PRIORITY = "100" |
| 22 | ALTERNATIVE_${PN} = "functions" |
| 23 | ALTERNATIVE_LINK_NAME[functions] = "${sysconfdir}/init.d/functions" |
| 24 | |
| 25 | # Since we are only taking the patched version of functions, no need to |
| 26 | # configure or compile anything so do not execute these |
| 27 | do_configure[noexec] = "1" |
| 28 | do_compile[noexec] = "1" |
| 29 | |
| 30 | do_install(){ |
| 31 | install -d ${D}${sysconfdir}/init.d/ |
| 32 | install -m 0644 ${S}/rc.d/init.d/functions ${D}${sysconfdir}/init.d/functions |
| 33 | sed -i 's,${base_bindir}/mountpoint,${bindir}/mountpoint,g' ${D}${sysconfdir}/init.d/functions |
| 34 | } |